Your config steamvr vrsettings

edited June 2017 in Support
I am just curious to see the settings everyone uses.

Remember to make a backup copy of your current settings file first if you plan to experiment with new settings.

Location: \config\steamvr.vrsettings
What I added for Nolo use: activateMultipleDrivers(true) and forceFadeOnBadTracking(false)

I think there is a separate scaling (other than renderScale) for the menus in SteamVR but I forgot what it is called.

Observe that the last lines inside { } are without commas. My file looks like this:

{
   "driver_vridge" : {
      "fakeSensorEnabled" : true,
      "hmdMode" : 0,
      "renderScale" : 120,
      "windowHeight" : 1080,
      "windowWidth" : 1920
   },
   "steamvr" : {
      "activateMultipleDrivers" : true,
      "forceFadeOnBadTracking" : false,
      "enableHomeApp" : false,
      "mirrorViewGeometry" : "0 0 1600 900"
   }
}

Comments

  • What do all of those do?  (minus the obvious ones)
  • edited June 2017
    "fakeSensorEnabled" : true,
    For example Dirt Rally thinks there is no sensor/HMD connected otherwise every few seconds. Can also be avoided by constantly moving the head but that is more annoying.

    "hmdMode" : 0,
    Not sure what this means.

    "renderScale" : 120,
    I think of this as supersamling in vridge. 120 means 1.2 times the width and 1.2 times the height which is 1.44 times as many pixels. Reduces jaggedness of straight lines. Increases readability of text in games. Just remember that it increases the strain on the GPU. Also remember that the view often is mirrored to the computer screen as well which makes the GPU work harder. I believe the superscaling you can set in SteamVR gets multiplied with this as well. If you have a HMD that uses more than 1:1 scaling (like Pimax, Vive and Rift) it is also multiplied again. Subsampling can also be used to run on lower spec machines but at the cost of being more blurred.

    "windowHeight" : 1080,
    "windowWidth" : 1920
    These are basic.

    "activateMultipleDrivers" : true,
    I am not sure if this setting was needed when I only used vridge.

    "forceFadeOnBadTracking" : false,
    To get rid of the grey screen when you lose tracking.

    "enableHomeApp" : false,
    Maybe to not run in desktop environment?

    "mirrorViewGeometry" : "0 0 1600 900"
    Maybe the position (I think 0 0 could mean it is centered on the computer screen) and size of the mirrored view?
  • edited June 2017
    Ahh, I learned a few things!  Thanks! :)
  • can you force the change the position of controllers with this? because mine show up behind me
  • @Phillip I have this strange issue also
  • I've had situations like that happen all the time, but almost every issue with the controllers being in weird places was fixed by simply calibrating yourself with double tapping the system button on each controller.  You're supposed to look forward and hit them both so it can orient the controllers.  Sometimes I need to redo it in game, and I'll just keep making little turns and doing it until they're back where they should be :P
  • yeah, that doesn't work, I can get it to work in DemoScene, but not in steamvr
  • Are you using driver version 0.5? Earlier drivers had problem with 180 degree turning.
  • I didn't even know that there was a button for that, and it doesn't seem to work anyway. I also have the latest nolo drivers.
  • I read somewhere that super-sampling in SteamVR uses a new scale. Old 1.0=new 1.0, old 1.1=new 1.2(1), old 1.2=new 1.4(4) and so on. Old 2.0=new 4.0. The new values represent the factor increase in pixels rounded to one decimal. Not sure if it affects renderScale.
  • Right now these are my settings:

    {
      "driver_vridge": {
        "fakeSensorEnabled": true,
        "hmdMode": 0,
        "renderScale": 0,
        "windowHeight": 792,
        "windowWidth": 1408
      },
      "steamvr": {
        "activateMultipleDrivers": true,
        "mirrorViewGeometry": "0 0 1280 720"
      }
    }

    I am still testing a bit though. I will probably try a higher resolution next time. Had a problem with the phone getting warm and the whole thing going laggy. Trying to figure out exactly what caused this.
  • edited June 2017
    "enableHomeApp" : false,
    I realized this is regarding to SteamVR Home, the new social space.


    Caldor: You can try lowering the screen brightness, using different encoding settings in RiftCat, adding more ventilation/fan on the headset, using USB tethering between phone and computer and enable flight mode on the phone and disable charging the phone battery over USB.

    I have not seen
    "renderScale": 0,
    before, is it the same as
    "renderScale": 100,
    ?

  • Zunhz the heating issue was mainly due to HEVC it seems. A setting in RiftCat that compresses the video signal more I think, but it gives extra work for the phone. After disabling that I have been able to run VR at 1440p without getting the issue with the controllers getting as laggy as they did this one time.
  • Here is more information on setting a different super-sampling for the Steam menues and the games: https://www.reddit.com/r/Vive/comments/59go2a/new_option_to_set_rendertargetmultipler_for/ Basically it looks like this: "steamvr" : { "renderTargetMultiplier" : 1.5 }, "compositor" : { "renderTargetMultiplier" : 0.1 } were compositor is the Steam menu/dashboard environment.
  • Guys I have tried you configs and they dont work for me!!
    when i delete the Steam vr-vrsettings file and it creates a new one, all i get is:
    {
      "steamvr": {
        "activateMultipleDrivers": true,
        "mirrorViewGeometry": "0 0 1280 720"
      }
    }

    this lets my phone connect like a hmd (great) but then won't allow me to connect my nolo  :'( (not great the nolo driver says connected but is not). i've tried all versions. then i start to add the rift code as you have done and restart everything and now i can't even get my HMD/phone to work!! the error in steam is that something went wrong 301 error,
    it's not a tethering problem as i'm using wireless that works great, I do know that Steam did update their VR drivers.
    any help much appreciated. 
  • Try this to fix the 301 error:
    1) Find openvr.vrpath file in <user>/AppData/Local/openvr (might be hidden)
    2) Backup openvr.vrpath (by copy+paste)
    3) Delete openvr.vrpath



  • edited June 2017
    If you have programs complaining about losing/missing connection to headset in games while using Revive ( https://github.com/LibreVR/Revive ) you can try adding this (do a backup first):

      "revive" : {
          "IgnoreActivityLevel" : true
       },
    Edit: If you want to disable Steam Home:
    "enableHomeApp" : false,
    in "steamvr" environment.

    I also found two more options for the mirror view in steamvr environment:
    showMirrorView (set it to true to show, false to hide)
    defaultMirrorView (should let you chose left, right or both eyes)

    Edit 2: defaultMirrorView might have been removed, you are supposed to chose it directly on the window and it should remember the setting between sessions.



  • Update on SS in SteamVR:
    allowSupersampleFiltering (enable/disable texture filtering)
    supersampleScale (replaces renderTargetMultiplier in "steamvr" environment)
    renderTargetMultiplier (still used in "compositor" environment)
  • edited June 2017
    supersampleScale uses a new scale that is proportional to the factor increase of pixels.
    Old 1.2 SS is new 1.4 SS.
    Old 2.0 SS is new 4.0 SS.
    In short, square the old SS value and round off to one decimal to get the new SS value.
  • I reinstalled all my VR software and drivers, and now my settings look like this:

    {
       "driver_vridge" : {
          "fakeSensorEnabled" : true,
          "hmdMode" : 0,
          "renderScale" : 0,
          "windowHeight" : 1440,
          "windowWidth" : 2560
       },
       "steamvr" : {
          "activateMultipleDrivers" : true,
          "defaultMirrorView" : 2,
          "mirrorViewGeometry" : "272 115 1280 720"
       }
    }


    I am not sure, what does the render scale do? I asked once, and it says it will render it in a higher resolution... but is it like when you on the desktop run a game in 4k, even though the monitor is 1080p and you get some extra details due to the higher resolution it gets rendering in, before being outputted as 1080p? Reading through this thread, it seems it was already answered, guess it is what I suspected it to be.

    I will probably try to add the stuff about the Steam menus to make them use super sampling. They are not exactly clear to see at the moment. Any way to stop the menu from being transparent? I was trying to setup some home stuff, and the menu is not very easy to see, I had to go to that TV to use it as a background.
  • Caldor: I think render scale is a kind of super-sampling.
    You can set super-sampling for SteamVR menu/dashboard with
    renderTargetMultiplier (in "compositor" environment).
  • Hello I need help - I am new I want to know about a better experience. I own NVIDIA GEFORCE GTX 1070 GAMING X 8GB and the newest HTV wive, all the newest Windows 10. What parameter shall I change to have a better video experience. In my steamvr.vrsettings there is only this: 
    {
       "keyboard" : {
          "TutorialCompletions" : 1
       },
       "steamvr" : {
          "background" : "C:\\Program Files (x86)\\Steam\\steamapps\\common\\SteamVR\\resources\\backgrounds\\viveNight.png",
          "mirrorViewGeometry" : "0 0 1080 600"
       }
    }

    I read that I should change something like renderTargetMultiplier" 2.5 Shall I add this, please help? Can I achieve a better resolution? 
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!