Hmd and controllers no connection

Both my controllers and my hmd has a green light, as if they connected correctly, but the base station has a red light on its power button. In the NOLO driver / app, it says the base station is connected, but not the controllers and not the hmd.

I am trying to run the pairing setup some more times, but cannot find others with this problem.

Seems the 4 meter cable I got is not working, same problem as others have had it seems. My phone is not recognized with this cable, but it is with pretty much every other cable I got. I am wondering if it might not be enough power in the port to support a 4m cable maybe? Not sure. It does charge the phone, but Windows 10 does not recognize it.
«1

Comments

  • Been trying different things. Cannot find any firmware or driver updates for NOLO. The base station is still said by the driver to be connected, even though it still has a read light. It is making this vibration and noise as it seems it should. I long press the button on the back to pair my controllers and the hmd. I pair each controller one by one, then the hmv. Then I single / short press the base station pairing button, and they all turn green... except the base station which goes from blinking green back to red. The NOLO app still says only the base station is connected.

    I have tried restarting my Windows... which is Windows 10. For a short while I could not run the NOLO App, but updating .NET 4.7 / installing .NET 4.7 solved this problem. I restarted the computer again, also tried pairing the hmv while it was connected to a computer USB port. Nothing seems to help.

    Only the base station will connect, but nothing else.
  • edited June 2017
    If you want "Use Cardboard to Play SteamVR Games",
    note: https://www.nolovr.com/android-riftcat
    The controller can be seen in Step9.
  • edited June 2017
    I have followed that guide to step 7 several times. Step 8 and 9 seem impossible because the hmv wont connect and the controllers wont connect. Not so it shows as connected in the driver anyway, they do have a green light.

    When I open SteamVR it shows the headset as connected. Nothing else. The NOLO app shows the base station as connected, nothing else. I try to do step 8 and 9, but it just does not seem to find the controllers or the head mounted sensor, nor the controllers. But it wants to find the hmv first I think.

    I did try to connect the controllers with USB once... one time one of them did show up as connected after installing some drivers. Then after I disconnected it, that stopped working again and then next time I connected it it just said that USB device was not recognized or it would just not do anything when connecting the controller.
  • Open the steamvr.vrsettings file with an editor,
    C:\Program Files (x86)\Steam\config\steamvr.vrsettings

    Set "false" to "true" for "activateMultipleDrivers".

        "Steamvr": {
           "ActivateMultipleDrivers": true,

    Right click on the nolo icon in the taskbar, select exit, run nolo again and check.
  • That setting is already set to true. This is the full settings:

    {
       "driver_vridge" : {
          "fakeSensorEnabled" : false,
          "hmdMode" : 0,
          "renderScale" : 170,
          "windowHeight" : 1440,
          "windowWidth" : 2560
       },
       "keyboard" : {
          "TutorialCompletions" : 1
       },
       "leap" : {
          "gripAngleOffset_lefthand" : 0,
          "gripAngleOffset_righthand" : 0,
          "renderModel_lefthand" : "vr_controller_vive_1_5",
          "renderModel_righthand" : "vr_controller_vive_1_5"
       },
       "leap_gestures" : {
          "GrabPressed" : "GestureWithin:LowerFist[0.5,1.0]",
          "MenuPressed" : "GestureWithin:FlatHandPalmTowards[0.5,1.0]",
          "SystemPressed" : "GestureWithin:FlatHandPalmAway[0.5,1.0]",
          "TouchpadAxis[0]" : "GestureAxis:ThumbPositionX[-1.0,-1.0]",
          "TouchpadAxis[1]" : "GestureAxis:ThumbPositionY[-1.0,-1.0]",
          "TouchpadPressed" : "GestureWithin:Thumbpress[0.5,1.0]",
          "TouchpadTouched" : "GestureWithin:Thumbpress[0.0,0.5]",
          "TriggerAxis[0]" : "GestureAxis:TriggerFinger[0.0,1.0]",
          "TriggerAxis[1]" : 0,
          "TriggerPressed" : "GestureWithin:TriggerFinger[0.5,1.0]"
       },
       "perfcheck" : {
          "warnInHMD" : true
       },
       "steamvr" : {
          "activateMultipleDrivers" : true,
          "allowReprojection" : true,
          "mirrorViewGeometry" : "0 0 1440 810"
       }
    }
  • edited June 2017
    Oh yes and VRidge itself is working as it should. Its only the controllers I am having problems with. Seems strange to me that hmdmode is set to 0, not sure if that is how it should be or not.

    Another thing that might be relevant, I have been using LEAP Motion controllers before I got NOLO VR with VRidge. Could it be conflicting somehow? I usually close that app down completely and the LEAP Motion is not connected.
  • I decided to try to NOLO VR for mobile apps, and NOLOTetris is working straight away it seems :)
    https://www.nolovr.com/android-mobile-vr

    I connected the hmd (or is that my headset? The sensor you place on the headset) to my phone with the OTG cable like I did when I was pairing these devices. The base station is connected to my PC in a USB2 port, and its LED is finally green, but that did not help me find the hmd or the controllers in the NOLO app, even though everything is now green. But when I disconnected my phone from the PC and instead connected the hmv to my phone, I could run NOLO tetris, the controllers get connected and I can play the game fine.

    So I am guessing my NOLO kit is working, its probably just some of these settings on my PC that stops me from using it for SteamVR. I suspect its because I had already set the whole thing up for VRidge, RiftCat and LEAP Motion controller. Just not sure what settings I need to change.

    I also find the guides a bit unclear about what needs to be connected to my with USB? The guides do not show any cables used for the base station, but the NOLO app wont show the base station as connected, unless I connect it to my PC.
  • edited June 2017
    I noticed the guide says to chose Freetrack orientation and position in VRidge in step 7, I had chosen Phone orientation and freetrack position.

    Did not seem to help that I changed this setting though. Well, except now it wont do any head orientation since the HMD is still with "no connection" in the NOLO VR app and in the SteamVR app.
  • I used Windows 7 and at the beginning, the software can not find anything, then I try to use vista mode for software, then everything works perfect with no latency
  • @Caldor: render scale 170 is pretty high. What kind of graphics card do you have?
  • I have a GTX 1080 and my CPU is an Intel 6700k i7. 16gb DDR4 RAM.

    I have begun setting the render scale down... not exactly sure what the render scale does. The headset is working quite well though. 1440p, 60fps. Until I set it to Freetrack orientation and position, instead of he phone for orientation, looking around worked very well.

    I will try running with other kinds of compatibility later.
  • edited June 2017
    Render scale should be some kind of super-sampling. It helps straight lines being less jagged and text gets easier to read. 170 means 1.7 times 1.7 more pixels for the graphics card to handle, that is 2.89 times more than with the default render scale of 100.
  • Ahh, thanks. Did not seem a problem for my graphics card. Its not the most high end graphics I have been trying out anyway.

    Seems I might be screwed though, I am still not closer getting NOLO VR working. Only for mobile is it working and only two mobile apps for NOLO VR so far. I tried uninstalling LEAP Motion controller, the system I used before NOLO for tracking. It did not help. Not sure what to do. The base station, whether I turn it on or off, the NOLO app still claims to have found it, so I am thinking the problem might be that the NOLO app has found something else which it then thinks is the base station.

    I now actually have two days to test this, so I really hope a solution can be found. The Steam summer sale is also active now so I hope to figure out whether this will work for me enough to try out some of the HTC Vive games with this. But if it keeps this up, not finding anything other than the base station in the NOLO app, I guess this is a no go for me.
  • Really sad to hear its still not working @Caldor. Do you have another PC to test on, even if its not as high specs?

    I think it might be worth re-pairing the controllers, and head marker, to the base station while connected to the PC!
  • I have tried re-pairing the controllers and head marker about 10 times now. Both when the head marker was connected to the phone and when the head marker was connected directly to the PC. I do have a laptop I can test on. It runs Windows 7, and I guess that might help... I will give that a try tomorrow.
  • Did not help... not really seeing any fix for this, it must be the hardware that is the problem. I have asked them to have it replaced.
  • Can you try holding the base station in your hand and hold it very still with the LED pointing up to see if the LED turns green?
  • edited June 2017
    Be sure to uninstall EVERYTHING first (leapfrog software and DRIVERS (in device manager), SteamVR, RiftCat and Nolo Drivers) just to be sure everything is clean to install.  Delete the SteamVR config file.  Unplug all the USB stuff (phone and any Nolo stuff connected). Restart computer. Install only the Nolo drivers and run the Nolo app. You shouldn't need RiftCat or SteamVR installed to get Nolo connected, so you can reinstall them once Nolo is up and working.

    Make sure the basestation and controllers are fully charged. (Plug them in with the wall plug and tri-split cable until the red leds turn off)

    Just to be sure you've got the right setup;

    -the *headset marker* should be the ONLY thing connected to your computer.  Connect it with the black only cable now. (Don't worry about the phone for now, until you get Nolo Driver to show its connected to all the devices.)

    -next, turn on the base station by holding the top button (power button)

    -hold the pair button on the back of the base station until the top led blinks and the controllers and headset markers leds turn red.

    -pair the two controllers by holding each controllers sliver button, one at a time, until they each rumble. 

    -pair the headset marker by holding the button on it until the led flashes once.

    -finally press the base station pairing button one last time.  The controllers and headset marker should turn green.

    Cross your everything and check the Nolo app,  does the devices show connected?

    if not, try closing the Nolo app and reopening it...

    thats all all I got I think.  Good luck ;p


  • The base station LED is green now, has been for a while. On my laptop which is the Windows 7 computer I installed the NOLO driver and app for the first time, installed Riftcat for the first time, SteamVR was not installed, and I then connected the base station to it. If I am not to connect the headset market to the computer, then how would it get power, or a connection? Connecting it to the phone makes sense for the pairing, but after that my phone needs a cable to the computer or the bitrate would be too low if it only has a WiFi connection.

    But yeah, I did try connecting the headset marker to the phone and connect the phone to Riftcat over WiFi, but that did not help either.

    I guess I will make one last try. Uninstall all drivers and Riftcat... I guess I could uninstall Steam VR as well, then only install newest NOLO drivers/app, only connect base station, turn on base station, pair it all and see what happens. I guess I have to take a look in devices and make sure everything is uninstalled their because my computer did try to install the controllers when I connected those... even though I think it failed to find drivers.

    Then I guess I will do all of this on the laptop as well if it does not work, just to be sure.

    I wish they would update their support page guide for Android headset on Windows, because it does not explain very well what to connect to the computer with USB exactly. It has images of the base station NOT connected to the computer. That is a bit confusing. Only with trial and error could I conclude it needs the base station connected tot he computer with USB.
  • @Caldor: Does RiftCat work for you without Nolo?
  • Wait... the headset marker is the only thing to connect? Not sure I have tried that. As for the 4 meter cable... I do not want to rely on it at all, since nothing I connect with it seems to get recognized by my computer. Whether its connected to the striped or black cable on it.
  • edited June 2017
    Hmmm... now I tried connecting a microUSB to male USB converter to the 4m black cable, then I connected a female to female USB to that, and I connected a microSD USB reader to it with a microSD card in it... and that did work. (EDIT: Nope... it failed to read as soon as I tried running something for it, even though I am pretty sure a micro USB is probably some of the least bandwidth and power consuming devices you can find)

    I guess the cable might be working... I have also had a suspicion that the issue might not be with the cable... but could be that due to the length of the cable the phone does not get enough power... although not sure that ought to be a factor.

    But I do hope I could find some way of getting those two 4 meter cables working. I tried to uninstall any seemingly related drivers. I also installed Oculus on this a few months ago which I had borrowed... I am guessing that might have some impact as well, and I noticed that I still had a driver installed for my LEAP motion... but all of this only ought to be a problem on this computer... but then I did connect both the base station and the headset sensor at the same time, and I know that if I connect one or two controllers, that will stop my base station from being listed as connected in the NOLO app... I am really hoping this is the real cause of my problems.

    Just waiting for my controllers to be fully charged now so I can make these final tests.
  • edited June 2017
    I use the all black 4 m USB cable between the head marker and the computer. Do you have two shorter USB cables you can try with? Also, if you have never got RiftCat to work I would focus on that before adding Nolo. Try with 20 Mbit/s in RiftCat settings and USB tethering.
  • Yes, the headset marker is the only thing you should connect to the computer.  The controllers and basestation should NOT be connected to the computer...  I think some people have been having issues with the 4m cable, so trying first with a know to work microUSB might be useful in trouble shooting.  I just found out many people are having issues USB tethering their phone via the white stripe 4m cable and that did fix my issue with RiftCat.  The 4m black only cable works for my headset marker connection.
  • edited June 2017
    I have other cables, I have got Riftcat working with at least 80Mbit/s, I think I got some issues when I went up to 95Mbit/s, but it is 1440p at 60fps. Not sure it makes a difference. I am using my phones USB3 to USB-C cable, so that should give it a... hmmm, not sure what USB3 speed is. I looked it up recently, its pretty fast. A USB-C port in my computer would be better though, but might not make a difference for this. USB-C is twice as fast as USB 3.0 though.
  • Well... those controllers take much too long a time to charge.... lol... one did turn green JUST now... well, guess I will wait 5 more min. The other controller might be close. Was about to try to excuse me going to test them now.
  • Sucks... did all of this, but I guess I might even have tried this before as well. I followed the whole list you made kinnikinnick, first I did the pairing with the app running, nothing changed. Nothing connected. Only the headset marker connected to the PC. Then I tried restarting the app. Still no connection. Then I closed the app, redid the pairing, restarted the app, still no connection. Everything turns green when I turn on the base station, the headset marker, the base station itself... unless I am moving it around, then it blinks between red and green a lot. The controllers are also both green. Unless I am doing the pairing.

    I guess I will try all this on the laptop now.
  • woot... omg... that is so silly. I did the whole thing on the laptop... all of it still failed. I was very put down. Then I figured maybe I should try to test another cable, since this one cable I had used which was not the 4 meter cable had not been used for anything other than charging and the headset marker... tried the 3 cable charger thingie, and it made a sound when I connected the cable, the again when I connected the headset marker... that seemed promising, so I ran the NOLO app... and sure enough it was green, and it has ALL sensors connected  :D Happy days ahead.
  • edited June 2017
    @Caldor: Good, you are making progress! I run the programs in this order: Vridge on phone, login to Steam, start RiftCat and click Steam icon, wait for everything to start up, run Nolo (if Nolo crashes I close Nolo and wait 10 seconds before starting Nolo again). Then I click on Steam to focus on it. Put on HMD and hold controllers. Press button on head marker (while facing the base station) if height seems wrong and/or run OpenVR advanced settings with Floor fix. Double click "O" button on left controller, double click "O" button on right controller (while facing the base station). Then I start the program I want to run using the controllers.
  • I got it all working :) Even switched that one DLL to make my driver a ceiling mount driver... that sure makes everything run much better I think.

    I think I mostly just keep the NOLO app running, unless it crashes when I close Steam VR while its running, maybe because I close it down in the wrong order, then I close Steam VR completely, rerun the NOLO app, then launch Steam VR again through Riftcat and it usually works, if the controllers are connected and in range of the base station.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!