Base station tracking wrong?

Just recieved my NOLO today, having an issue with tracking though, it seems for the head the orientation tracking is good but the position is completely mixed up, maybe stuck in ceiling mode? (it seems left/right motion translates to circular position change, up/down are switched, and forward/back also is somehow mapped to up/down)
Seems to be the case with both mobile (tetris) and SteamVR games (after setting forward as well)

Comments

  • I've run into this issue as well. It happens sometimes (who knows why), Nolo team is going to look at it, but in the meantime, this is how I fix it:

    Turn off and unplug all Nolo hardware.
    Stop Nolo app.
    Turn on base station.
    Plug in HMD sensor and face it upright at the base station until light is green.
    Turn on controllers and point them directly at base station until lights are green.
    Start Nolo software.

    Enjoy until it happens again, repeat.
  • Still no luck :/
  • I've found that actually all I need to do is unplug the HMD sensor and replug it (so far) when this happens. No need to stop the software or turn off anything else. I am working with the Nolo engineers to improve the product before (1.0) release, and they have been very responsive so far. I've brought up this issue with them and they are looking at it (or will be next week, the dev in charge of this is currently traveling).
  • edited July 15
    Hmm...many reboots, unplugs, repairs, etc etc, have yet to see it work correctly, and it is always exactly the same.  Hope they release a fix soon, hope its not a faulty unit
  • I'm beginning to think it may be an issue with where the base station is placed. If it is generally above where the HMD is (I had it on top of my monitor) then the runtime appears to put the tracking in "ceiling" mode. If it is on the desk (ie. generally below where the HMD is) then it seems to work OK (so far).

    If this is the case, then the runtime should not make any decisions based on what it thinks is going on and rather let the user set this in the Nolo app.

    @sprylitol Have you tried runtime 0.5 (I haven't as I need latest) as I believe this is before Nolo supported "ceiling" mode?

  • Tried 0.5, same behavior.  Also noticed that it is same for the controllers.
  • If the monitor or TV is on, turn it off and test it. It looks like you have the same problem. http://forums.nolovr.com/discussion/342/low-quality-tracking-or-base-station-defect-shaking-all-the-time#latest
  • Thanks for the suggestion but sadly it has exactly the same behavior when used in dark room at night.
  • I haven't had this issue since I started using the base station on the desk (ie. below where the HMD is on startup, and generally below). Before that I would have it randomly switch into "not working properly" mode either on startup or in the middle of a session. Maybe it is a firmware issue of some kind, I've noticed my 2 controllers behave slightly differently (sometimes one would be in "not working properly" mode and the other would be fine, they have different auto power off times), which can only be firmware differences.

    In your case, if the hardware was faulty, it wouldn't track properly, not invert some of the axes, making it more likely to be a firmware/driver issue. Hopefully @hettylool will join in this discussion. Here is the issue on Github if you want to add anything to it:

    https://github.com/NOLOVR/NOLO-Windows-SDK/issues/5

  • edited July 16
    Can recreate this issue any time by double-clicking the power button on one of the remotes. There's no way (that I can find) to recover this.
  • I've found that this is a bug in the "recenter" action (double-click system).

    https://github.com/NOLOVR/NOLO-Windows-SDK/issues/8

  • Awesome that its located!  Still have not seen it successfully track the HMD once.  Tested again earlier and noticed one controller at least was moving up/down correctly for a few moments.
  • @sprylitol Please try to unistall the NOLO driver completely from the control panel and install the newest version? Then try the forward setting first. Make sure the base station is in front of you but not on the ceiling. If there is still the same problem, could you please shoot a video for us and send it to support@lyrobotix.com?  Sorry for the inconvenience.
  • I also have this exact same problem.  I also see that when the head tracker gets far away, it gets completely mixed up (still tracks, but in a different coordinate system).  I have tried this directly connected to the PC with the visualizer and directed connected to a phone with the tetris app, and even my own app developed in Unity.  The tracking is smooth (most of the time), but mixed up.  It's not related to recentering or resetting the orientation.  It's clearly some sort of bug in the firmware, so that it's reporting incorrect positions.  

    I've tried everything at this point.  Could be defective hardware for our batch. I'll send a video through email.

  • Anyone else besides @sprylitol and me having this issue?  Not getting anywhere with @nolo, who believes it to be a driver issue.  However, that makes no sense in that the "driver" is a windows thing (and, of course, I have the latest driver), and the behavior is the same on every platform (gear vr, cardboard, windows).  The raw hid data must be the problem, either because of a hardware issue or because of some strange calibration/initialization issue that can't be resolved.  Unfortunately, the HID data is encrypted and the protocol unpublished, so only @nolo can really diagnose the problem.  
  • Just an update on this.  I sent a video to the nolo support team, and they sent me a fix for some bug in the basestation that affected me.   It works now! 
  • I have a similar issue but not the same one.

    When i load into steam vr through riftcat all i see 90% of the time is my head stuck in the ground.

    That's not all though. If I restart my pc and phone a bunch of times i will get the odd lucky time that I am in the right place. Ocassionally if I am super lucky it will actually track perfectly where I am. The times that it does, it is just super laggy which means that rotating the controllers in steamvr and seeing the lazer's position only moves every like 5 seconds and warps to where it was a few seconds ago.

    I've been sitting here for 2 days trying to figure out what I can do to fix these issues but am getting on the verge of giving up.

    I have a good pc, a 5ghz router and wifi connection, basestation set up on the cieiling, everything is paired correctly.......

    I just cant justify putting any more time into something that seems unsolveable......

    Please, someone, correct me if I am mistaken here..... but this product is seeming... well.... 

    not good. I hope im wrong but I feel as if i was scammed
  • @lestysone try the free trial of WalkinVR it will let you manually adjust yourself out of ground.


    I heard there is an advanced openVR tool that might do a floor fix too that is free.
  • This happened to me until I paired everything on the floor for some reason.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!