BETA NoloVR compatible driver for iVRy available.



  • @djelinek ; With regards to your wireless Nolo question, I've had a look at their Android SDK, and it hasn't been updated in a long time. It combines poor design (polling) with a very outdated driver that is probably not able to talk to the new firmware. There's no support in the Android SDK for velocity/acceleration so it's not possible to do throwing etc.

    In short, even if there were enough (Android) users using NoloVR with iVRy, the Android SDK is so far behind the PC SDK, that the experience would be much poorer in comparison, if that SDK was even able to talk to the new firmware. Doesn't seem to be worth the effort to spend a lot of time on a sub-par experience for a handful of users.
  • edited January 12
    In any case, I will continue to offer the (current) OpenVR 1.0.11 and before compatible driver for iVRy linked in this thread. I've had to take the Nolo controller code out of the iVRy driver in order to get it to build with the new OpenVR SDK, meaning that further updates to the iVRy SteamVR driver won't be available in the NoloVR version.

    This is going to be a problem going forward for every SteamVR driver that uses Nolo controllers - either rewrite the driver or have to build it against older versions of the OpenVR SDK (while OpenVR/SteamVR still supports the "legacy" controller interfaces).

    I'm open to suggestions as to how to proceed, and of course it's possible to rewrite the driver to support current and future OpenVR SDKs, but it would take a massive uptick in interest from Nolo users (and/or the company itself) for this to happen.

  • @uekami2000 ; Thanks for the nice words! :)

  • Okay... sadly, but i understand why you are leaving nolo support out of your driver... Lyrobotix seems to be not very fast responsive. They do kind of the same thing with vridge (and it's suposely supported)...
    So, when i should change your driver?
  • @Tux0Topo ; The driver linked in this thread (1.08.3) is most likely the final NoloVR driver for iVRy.

    @admin LYRobotix needs to step up to the "partner" role they offered to me. I have helped them improve the design of their PC (USB) SDK. I've filed bugs in their Github to help them improve their product (virtually noone else has). I've been keeping my driver up to date with their SDKs. I've worked around bugs/limitations in their SDK and hardware to provide the best experience for their customers. I've promoted their product on social media. In return, they have refused to give me early access to their SDKs to help them test and to prepare my product for their releases. They've pretty much ignored every bug report I've made. They've refused (for whatever reasons) to even mention anywhere in their online presence that iVRy even exists. I really don't see why I should spend any more time developing for this product.
  • Its a shame the company wont step up. I can see great things with this app for the Nolo. I finally was able to order my Nolo and have had iVRy on my iphone 7 plus just waiting for the moment it showed up. Ive played subnautica and like games in vr using your app and it worked flawlessly. Will the Nolo still work with steamvr at this point using iVRy? as far as i can tell i have the latest drivers installed on the phone and pc. Ill find you some users if this works well for me. Wish i knew what i was doing and Id give you a hand with coding and what not :P anyway, all the best from Australia mate.
  • @aussieyank82 Thanks, Nolo will continue to work with the current iVRy driver for as long as LYRobotix doesn't change the USB-HID SDK significantly and 'legacy' input drivers are supported in SteamVR. Definitely don't want to exclude Nolo users, so will figure out something (possibly using 3rd party solution like Driver4VR) moving forwards.
  • Silly question, but the iVRy driver without Nolo, can be used toguether with the original Lyrobotix drivers, right? Maybe not the better sollution, but could be a decent trade, keeping iVRy and all Lyrobotix updates up to date...
  • @Tux0Topo ; Not to my knowledge. I would expect you will have a much better overall experience using the iVRy Nolo driver with iVRy than trying to cobble together a solution out of many parts.

    In any case, the NoloVR driver will also need to be updated to the new SteamVR SDK. As they haven't really updated the OSVR driver their driver is based on to newer OpenVR SDKs, I wouldn't expect this to happen until SteamVR no longer works with 'legacy' drivers.
  • just received my nolo and am now editing the steamvr file as your instructions in this thread have guided me to. Will post feed back here of my experience :)
  • Please use one of the following social media sites to discusss anything related to the iVRy app or driver. Any future announcements regarding the app or driver will be made there.




  • edited January 15
    I tried the driver when it became available for Android and had a few issues (mainly the viewport size and distortion) but didn't get a chance to test it further since because life got in the way. I did want to do more testing (especially since there's been a few updates to the Android app since) and provide some feedback if my issues were still present. (Or just buy the full version if everything was fixed)

    I understand not wanting to put in the effort to support the product if there isn't a large demand for it. As a end user it's disappointing but there are only so many hours in a day and you have to spend them where you feel it's most useful. For what it's worth, the iVry logo is now on Nolo's main website page as well as in their Facebok banner.
  • Interesting few days. Have had some Twitter user (jayw900502) pretending to be from LYRobotix being threatening and abusive. Fortunately, LYRobotix has confirmed that the person is just some random internet weirdo and not actually working for them.

    Have had many Nolo users contacting me to let me know that they are relying on iVRy to give them use of their Nolo hardware.

    Have also had to port the iVRy driver to the new OpenVR SDK. In the process of doing that, I had to spend a day porting the Nolo input driver to that SDK too (as part of porting/testing other input drivers).

    So, good news for iVRy users of NoloVR, the driver has been ported to the new OpenVR SDK, and so can be kept in sync with the "non NoloVR" version going forward.
  • Great news!!
    Weird about the crazy user...
  • The intrigues of the tech world... I'm sure someone could write a book about what happens behind the scenes at LYRobotix. Weirdo dude says:

    "no, I work there, but of course they don't need to know about this"
    "I'm planning to resign. This company is a 'weirdo' actually."

    Seems to know a bit about the whole NoloVR story, so either he's super crazy or there's a whole unknown world going on there. Definitely some kind of stalker type. Created a Twitter account (it seems) for the sole reason of trolling me. Follows some guy called "Bob Ivry", so poor Bob has probably been getting trolled too. :D

  • According to LYRobotix, this person definitely does not work for them. They believe it is someone who has been trolling them for some time now.
  • Driver porting to the new OvenVR is great news!
    By the way what are you planning to do in the future version upgrade of iVRy?
  • @iVRy What do you think about "Nolo Home" becoming a thing?
  • @uekami2000 First is PSVR and macOS support. After that, we see...

    @Pigney Have no thoughts on it. LYRobotix also wants to get into the "selling razor blades" game, it's a logical progression. However, nothing to do with what I do...
  • I've updated the NoloVR driver for iVRy to match the latest iVRy driver (1.08.6). This driver is a substantial rewrite of a lot of the controller portions of the previous driver, as is required to make it compatible with the latest OpenVR SDK (1.0.12), so please let me know if anything stops working.

    The latest NoloVR driver for iVRy can always be downloaded from:

    Unfortunately, due to the LYRobotix driver messing with the SteamVR "Chaperone" file (which is very bad practice and against the "rules"), you will probably have to continue to run SteamVR "room setup" every session. Maybe someone can petition @admin and/or @Lyuzhou to get this behaviour fixed. All of my attempts so far to get LYRobotix to do it "the right way" and not mess with "private" SteamVR files have failed.
  • We're working on both Android SDK and Windows SDK. We'll post a post here (Nolo developer forum) once they are available. If you've opted to "watch" our Github repo (, you shall also get email notifications when they get updated.
  • @Lyuzhou Please fix this issue in the USB-HID SDK. It's not OK (by any metric) and creates a bad user experience (not to mention messing up the settings for other headsets not using Nolo) to modify the "chaperone" file. I am tempted to patch the Nolo driver to stop it doing this myself, but it would be better if the driver was just fixed. Thanks
  • @iVRy Any idea how to fix the steamvr error " A key component of SteamVR isn't working properly" can't seem to fix it, only pops up when I start iVRy the second time. It's error 308.
  • @Pigney Can't repeat that, am able to start SteamVR multiple times with both iPhone and Android without getting that (or any) error, also haven't had it reported by anyone else, so have to assume it's something specific to your SteamVR setup. Chances are (if you're playing with Trinus & Riftcat) that you have multiple active drivers installed. I've had problems with those apps' drivers intefering even when they're not running, but not knowing your setup is just guesswork. Of course I can't support issues that may be caused by other drivers, so if you get this when you have uninstalled or disabled other SteamVR drivers, send me the files requested in this post and I'll try to help you further:

  • I've discovered some issues with "recentering" (double-click system button) with the current apps (iOS and Android). There will be a new version of the driver and apps available once they've run through the app store approval process. In the meantime, the workaround for "recentering" issues is to set "disableDeviceOrientation" to true (as detailed earlier in this topic).

    The new driver also terminates the Nolo "windows driver" if it's running when SteamVR is started (with the iVRy driver), so will coexist better with that driver (doesn't need it to be disabled or uninstalled).

  • edited February 5
    @Pigney The error you're experiencing is from the Nolo SteamVR driver failing to shut down properly (hanging on exit). Disable it in the steamvr.vrsettings file as detailed in this topic, or uninstall the Nolo driver for Windows.

    In any case the new driver (available soon) does all of this for you.
  • @Pigney Alternatively you can open the task manager and manually kill the process named "VR Server" when it happens, but iVRy's solution is cleaner.
  • So, it turns out, the "recentering" (double-click system button) issues are to do with the Nolo SDK driver modifying *private* SteamVR "chaperone" configuration files. I've patched that functionality out of the Nolo SDK driver shipped with the iVRy SteamVR driver so it's no longer an issue. Hopefully LYRobotix will fix this at some point, but until that time (because who can wait months for that?) I will patch any LYRobotix files so that they don't do this (modifying *private* SteamVR is an *incredibly terrible* idea that would be rejected 100% by Valve if they knew about it).

    I've also managed to disable the *incredibly buggy* Nolo SteamVR driver automatically, and terminate the Nolo windows driver (if it's running) so it won't be interfering any more. Needless to say, I'm not impressed that I've had to spend days working around intentional design flaws in the Nolo software.

    I've updated the NoloVR driver for iVRy to include these fixes. A new app version is on the way, but is not required to take advantage of the NoloVR improvements in the latest driver.

    The latest NoloVR driver for iVRy can always be downloaded from:

  • As soon as I download your driver windows defender deletes it claiming it's a virus. =(
  • @Failrunner You could click "more info" and "run anyway".

    In any case, I've set up that URL to download a ZIP containing the EXE now, which should resolve the issue.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!