Use your NOLO on SteamVR without the PC driver!

Hi all,

Looks like the latest beta for VRidge has rolled out the NOLO Untethered support! I can't wait to test this as it means no more cable struggles :smiley:

http://blog.riftcat.com/2017/08/dev-update-32.html

Comments

  • You'll want to switch to the BETA of the app too! https://play.google.com/apps/testing/com.riftcat.vridge

  • It's impressive that they've managed to get that working, and it's a great preview of what's to come (in terms of self-tracking HMDs), however I don't believe this configuration is going to be particularly useful, as having the tracking connected to the PC definitely has much lower latency than having to send the tracking data back from the phone over Wifi (tracking -> phone -> PC -> frame -> phone). Also, having the phone connected via Wifi (as opposed to USB) results in occasional frame drops and reduced quality overall. NoloVR tracking is borderline in terms of latency (due to only being 60Hz), when connected to the PC, so I'd be interested to see if it dips below "not nauseating" when running in this configuration.
  • Hmm I have a fine time in wireless on 5GHz, but then again I also run it in the same room as my desktop and have it connected by ethernet.

    Even with laptop on WiFi and phone on WiFi, a $100 5GHz router connected to the modem does the job well enough for me. Looking forward to trying it for input tonight.
  • @bigelowed ; Interesting. What resolution are you running at (assuming you can set resolution in Riftcat, never tried running it)? I've found that running iVRy over Wifi on Android needs to take a bigger drop in resolution than running it over Wifi on iOS to keep it looking good.
  • edited August 8
    My dedicated VR phone is only 1080p, I run it 60fps 11mbps. 

    My main personal phone is Quad HD so when I use that I do the 2560x1440 resolution and still 60fps 11mbps (or maybe 13mbps, it's adjustable). I have only tried that phone with the PC connected by gigabit ethernet but the phone still worked fine on the 5GHz.

    There is the very slight frame drop sometimes but usually it works well or recovers quickly 
  • bigelowed: do you have "activateMultipleDrivers": true, in your steamvr.vrsettings file? It would be really helpful if you posted your steamvr.vrsettings file. I am trying to troubleshoot why I get SteamVR errors (301 in Windows 7 and 405 and 305 in Windows 10) when I activate multiple drivers. I think it might have started 2 August when I didn't let WalkinVR update.

    Everything, including WalkinVR, works when I use Nolo drivers and USB cable to the head tracker. But I have to delete steamvr.vrsettings and let it be re-created.

    I don't get any head tracking and the two controllers does not show up at all in the new wireless mode but the video and sound works.
  • edited August 8
    That's a WalkinVR issue that was fixed yesterday if you update :) I haven't touched my SteamVR settings directly myself though

    Where is it?
  • Bigelowed hows the wireless with nolo
  • @AxleB Works really good for me!  I run a 5GHz Wireless AC TP Link Archer router and even with the phone and my laptop on WiFi it ran really well!
  • bigelowed: the file steamvr.vrsettings is in Steam/config folder. Good to hear the wireless mode is working for you. :)
  • This is my contents of steamvr.vrsettings:

    {
      "driver4vr": {
        "NOLO_Tracking_controller_0": "2 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0",
        "NOLO_Tracking_controller_1": "0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0",
        "VridgeControllerV02ID1": "1 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0",
        "VridgeControllerV02ID2": "2 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0",
        "controllers": "3,4",
        "source": 2
      },
      "driver_vridge": {
        "fakeSensorEnabled": false,
        "hmdMode": 0,
        "renderScale": 200,
        "windowHeight": 1080,
        "windowWidth": 1920
      },
      "steamvr": {
        "activateMultipleDrivers": true,
        "mirrorViewGeometry": "0 0 1920 1080"
      },
      "walkinvr": {
        "NOLO_Tracking_controller_0": "1 2 0 0 0 0 0 0 0",
        "NOLO_Tracking_controller_1": "2 2 0 0 0 0 0 0 0",
        "controllers": "1,2",
        "nolo_controller_0": "2-2-0",
        "nolo_controller_1": "1-2-0"
      }
    }


    And actually, I had to temporarily uninstall Driver4VR and WalkinVR while their sites are down (they keep trying to check for updates/open SteamVR to open themselves) so I might just delete their settings.
  • bigelowed: Thank you! SteamVR seems to like multiple drivers again after I downgraded the Nvidia graphics driver. When I was troubleshooting I upgraded to the latest drivers and forgot to revert when it didn't improve the situation. I am using version 381.89 again.
  • I'm on 384.94 and it works okay on my GTX 1060 !
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!