GearVR loading Oculus Home when trying to play Mobile VR game

Hi. My Gear VR headset (2016 version) that I included in the Kickstarted just arrived from Nolo... finally.
But now when I load a Mobile VR game (e.g. Tetris) and plug my phone into my GearVR it asks permission for the USB access, after I click chose yes it just loads to the Oculus Home. I've plugged the headset marker in and tried combinations of plugging in the short USB cable.
It seems I have to plug in with the USB C adaptor for the headset marker to power on. I don't know if this causes a problem.
Anyone else had this issue??

Comments

  • Ok, a bit more research and it seems there are no Mobile VR games that support GearVR at this stage. So now I wish I had ordered a different headset with the kickstarter. A long wait disappointing wait for a disappointing outcome...
  • The VRidge app is coming out soon for GearVR that supports wireless tethering to desktop. Other than that, yeah it looks like you would want a Cardboard VR headset.

    That said, unless you're a developer, there's maybe 4 apps so far for NOLO, simply because everyone's only recently getting their units! I can't wait to make some more apps for it though :) but spare time is hard to find :(
  • I think that with some package disabler, you can turn off the oculus gearvr service, and use nolo... Maybe that could work?
  • AFAIK, you need to modify the GearVR to plug anything else in while you are using it (at least on mine, the USB socket on the outside is just for taking a charger, it doesn't do comms, or output any power). You can disable the Oculus service to run "cardboard" apps which will then let you run some app over wireless to connect to SteamVR. I can't see a way without modifying the GearVR that you can use Nolo Android apps (including untethered Riftcat).
  • edited August 11
    @iVRy Yours is white with gray box? Then is SM-R322. It doesn't have OTG.
    The SM-R323 and SM-R324 (black ones) have OTG... That's why the GearVR selled by Nolo was the 323... Sorry!
    When i saw your pictures on instagram, i thought that you were aware of that...
  • edited August 11
    You can use an app to disable the Gear VR service that automatically launches the Oculus Home. That way you can run Cardboard applications in your Gear VR.

    This is the one I use: Play Cardboard apps on Gear VR
  • @Tux0Topo ; It is. I don't know too much about GearVR versions, so that's good info, thanks. I've got it to make iVRy a "proper" Oculus app so I can use the improved sensors, run it in high-framerate mode, not have to hack the software etc. I'll probably get the newest one with the controller soon and give this one to my brother.

  • @iVRy For deplyment, most probabbly you will need to use https://www.constructvr.io/ ...

  • @Tux0Topo ; Never use things like that, but thanks anyway!
  • Hello...I have the same problem: oculus home is always launching (with cable to pc or direct connection to my smartphone for nolo vr apps). I don't understand: there is an official video with someone running with latest gear vr headset and a Samsung S8 (same config as mine). Why is oculus home running??



  • @Impgnolo

    GearVR does not support USB pass through at the moment with Riftcat, only through wifi at the moment. They're working on it in their future updates. You need to download ConstructVR & download Vridge GearVR version on your Galaxy phone. You can follow the steps here https://www.nolovr.com/gearvr-riftcat

    If you still want to use USB tethering with your Galaxy phone you need to use a Google Cardboard VR headset. 


  • @Impgnolo

    If the app that's running is not a GearVR app, then the Oculus home will automatically launch when the phone is put into the headset. That is by design. As edinoryazizMY said, you need to get the GearVR version of VRidge to use it with that headset. (And it's not compatible with wireless just yet)

    If you want to play regular Cardboard apps, you need to disable the GearVR services. The app "Play Cardboard apps on Gear VR" that I posted about earlier is one way to do this.
  • @Zomby

    Does the "Play Cardboard apps on Gear VR" support USB tethering if it's enabled? 
  • No, this is a hardware limitation that can't be bypassed. The phone can't be a USB host and do tethering at the same time.

    That's why I use a USB-C Ethernet adapter instead of tethering. It only works if you have a USB-C phone though, like the Galaxy S8.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!