Controller not found with PiPlay 2.0.3.38

Hi,

I've been using Nolo VR with PiPlay 1.2.89 for a while without issue (I've had to play around for about 4 days to get it to recognize the second controller though, but in the end it somehow magically worked).
Since updating my PiPlay installation to version 2.0.3.38 though, my second Nolo controller is not picked up by either PiPlay, nor SteamVR.

I was wondering if any of you SteamVR/Pimax 4k/NoloVR Users out there have been successfully using the NoloVR with that version of PiPlay and if so, if you have any hints what might be the issue.

Things I've already tried:
- Pairing the Controllers/Headset Marker with the base station following the recommended procedure.
- NOLO Base Station Repair Tool
- Reinstalling PiPlay 1.2.89 (It doesn't pick up the second controller either)
- Reinstalling PiPlay 2.0.3.38 (no luck)
- Uninstalling PiPlay versions completely and installing NOLO Driver for Windows (doesn't pick up the second controller either)

I'm pretty much stuck and really would appreciate some help.

Comments

  • edited October 9
    Sorry for the problem caused.

    Please use this controller repair tool on your controllers one by one.
    (Users who don't have this exact problem please do not try this tool on your own!!!)

    Download link: https://drive.google.com/open?id=0B7VxsyPr8QP3WEhzbFVZQzhmbFE

    Please note: 
    1. Connect one controller to the PC, not the headset marker or the base station; 
    2. DO NOT DISCONNECT the controller until you see " Repair complete".

    Please pair all the devices again after the repair complete.
    We are willing to provide remote assistance via Teamviewer if needed.
  • Thank you very much for your quick answer.
    I'll try the tool as soon as I'm home and post the result here.
  • How long should the repair process take per controller?

    The progress bar stopped half way through the repair process about half an hour ago and hasn't moved since.
  • I found that this only worked if i used usb 3 ports, is that what you are using? 
  • After about 2h not doing anything I'm pretty sure the "repair" got stuck somewhere during the process and I closed the software and disconnected the controller.

    I reran the software with the other controller on a second PC, but the result was the same.

    Unfortunately, now both my controllers are defective and won't even turn on.
    When I press the Power button on either of the controllers, the LED just flashes red. As soon as I let go of the Power button, the LED is off.

    I'd really appreciate some help here.
  • @belly :

    I've had it connected to three different USB 3 Ports now, but none of them did the trick.

    Another strange thing I've noticed is that there is an "STM device in DFU mode" that keeps flashing on and off in  Windows "Eject USB devices" tray icon.

    That being said I just couldn't let it go and tried flashing the controllers again. When one of them got stuck again I used the "Mandatory repair" button. This led to the flashing STM device again. Pressing the "Mandatory repair" button again let the repair finish successfully.

    I'll check the controllers with the PiPlay version I mentioned in the title and post the results in a bit.

    Thanks for the help guys, I really appreciate it!
  • edited October 9
    ok, so the final verdict seems to be that regardless of what I do, the second controller does not show up as connected in PiPlay 2.0.3.38.

    @admin:
    1. Flashing worked after some trial and error.Thx for the Controller repair tool.
    2. Unfortunately, the second controller still won't work with PiPlay 2.0.3.38, although pairing worked flawlessly once the repair went through.

    Any further suggestions I might try?
  • Ok, after further trial and error, I can pinpoint the problem to one specific controller of the two that came in the NOLO package. No matter how often I ran the repair tool on that specific controller, it will not show up as connected. Neither in PiPlay 2.0.3.38 or any other version, nor in the original NOLO driver for Windows tray icon.

    @admin:
    Is there anything else I can try?
    Is there any additional information that I could give that may help you find a solution?
  • You can test it in standalone mode with an Android device (eg: with NOLOTetris on Google Play)
  • Thanks @bigelowed I'll try that as soon as I get the chance.
    I'll post the results here.
  • Great good luck!
  • Just a quick update:

    I didn't find the time to try it with my Android phone yet, but since the 20th October 2017 update of PiPlay (version 2.0.4.42) it's miraculously working again.

    Steps:
    1. Uninstall PiPlay 2.0.3.38 and all the other PiPlay components (can be identified in Windows Control Panel -> Software by looking for "pimax" in the vendor column)
    2. Restart PC
    3. Download and install PiPlay 2.0.4.42 from the pimaxvr website
    4. Start up PiPlay with the headset marker disconnected and the base station/controllers off.
    5. In PiPlay change to the devices status tab and connect the headset marker.
    6. Now turn on the base station -> The headset marker and base station should be picked up after a few seconds.
    7. Turn on controller one and wait for it to be picked up by PiPlay.
    8. Do the same for the second controller.

    Note:
    - I realized I had a ton of Microsoft Visual C++ Redistributable versions installed (from different games installed through steam). I uninstalled any versions prior to 2013 and reinstalled the 2015 version (x86 and x64)

    Thanks again for all the help from @admin and @bigelowed.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!