NOLO Firmware & SDK Update

edited July 16 in General

The first NOLO CV1 firmware update is coming! Currently it is under final test. The estimated releasing date will be the next Friday, Nov. 17th. Here are some key features.

1. Add velocity and angular velocity
- Improve the smoothness of positional and rotational tracking in Steam VR.
- Reduce latency by 30%
- Fix the throwing problem in some games and improve the throwing experience in all games

2. Optimize the synchronization algorithm
- Reduce jitter

3. Reduce the packet loss rate to 0.2% 
- Improve the stability of data transmission

* This firmware update works for every PC VR headset that compatible with NOLO, and works for RiftCat wire mode.

Detailed update documentation will be released with the firmware, we will also make a tutorial video for you to operate.

As for NOLO SDKs,

1. The next Unity SDK update will reduce the CPU usage. It will be released in late November.

2. The UNREAL SDK is under alpha test, The scheduled release date is December.

«1

Comments

  • Amazing news, can't wait!
  • That's some great news. Thanks for the update.
  • @admin Please send me pre-release software to test.
  • 4 more days!!!! JUST 4 MORE DAYS!!! WAITING!!!! AAARRRGGGHHHH!!! :D
  • Any ETA for the update? Hour? Please? :D
  • Anyone tested it yet? I'm at work but eager to know if it's an improvement..
  • edited November 2017
    When I click on blue circle "Check for update" the program NOLO_UPDATE crash. I use Windows 8.1. 64 bit (I have updated driver 0.11)

    Informace o výjimce: System.FormatException
       na System.Number.ParseSingle(System.String, System.Globalization.NumberStyles, System.Globalization.NumberFormatInfo)
       na NOLO_UPDATE.Form1.SetChecked()
       na NOLO_UPDATE.Form1.UpdateUI(NOLO_UPDATE.ProcessState)
       na NOLO_UPDATE.Form1.<SetChecking>b__22_0(System.Object)
       na System.Threading.ThreadHelper.ThreadStart_Context(System.Object)
       na System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
       na System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
       na System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object)
       na System.Threading.ThreadHelper.ThreadStart(System.Object)

    I hope that problem is in localization environment, I have Windows set for Czech language.

  • Any testing? Is safe to use? What about the vridge, is safe to use with its wireless configuration?
  • The problem solved. I change number format for US English. Both controller and headset are now updated to new firmware

  • Since it doesn't support the older driver anymore once updated, will compatibilty with the Windows USBHID SDK and Android SDK remain? Do already released apps need to be updated?
  • @Zomby ;We've already made the necessary changes in the previous SDK update.
  • edited November 2017

    Updated (with a bit of confusing), base station and controllers are unable to be paired (they are red marked, leds on controllers are both green but on head mark is still in red)

  • I have no problem after update, all is working OK, the tracking is more stable.
  • @Pinate Please try to pair the devices again if the update suceeded. The LED lights should be all solid green.
  • I'm update firmware on headset, base station and both controllers, but now HMD not paired with base station. I press the button on the marker, but the indicator blinks very weakly, not as before. Now only base station and both controllers paired together without HMD. Please help me.
  • @atangik Problem solved via email.
  • @admin  Thanks for the quick help!
    Another question, does it work with Pimax 4k and latest Piplay (2.0.5.46) after firmware update?
  • @atangik Yes, the latest version of Piplay supports NOLO new firmware.
  • edited November 2017
    Another "quality" software release from LYRobotix! Can't update firmware as app crashes with:

    "System.FormatException was unhandled
    Message: An unhandled exception of type 'System.FormatException' occurred in mscorlib.dll
    Additional information: Input string was not in a correct format."

    Do you guys even test this at all before sending it out?

    This is why I asked you to send me the software before your release so I could test it and not have our mutual customers dealing with this kind of issue. You will need to test and correct this issue before I will provide an update that supports this version.

  • About this bug I wrote before 2 days, solution is simple, read my post above.
  • @djelinek Thanks, it is simple. Funny they didn't find it in "testing" or fix it yet.

  • Yeah, this release is a bit buggy. Fortunately the FW update didn't brick anything.

    Bugs I've found so far (USB-HID, ZMQ is so out of date now it's unusable for SteamVR):
    - Battery level reporting is pretty much broken. It randomly works some of the time.
    - Controllers need constant recentering
    - Recentering only works if you point the controllers at the base station

    For some reason the controllers can't figure out which direction the base station is in (can't be that hard) and always start 90 degrees off. They reset(?) occasionally and go back to being 90 degrees off.

  • Is there any way to install the firmware via Linux?
  • @ShiYuMeng While it may be theoretically possible, as it seems they use a 3rd party firmware updater, I would expect it would be a lot quicker to install an evaluation copy of Windows in a VM and update the firmware that way than it would be to figure out how to update the firmware without their updater. A lot safer too, the potential for "bricking" devices during firmware updates is big.
  • Well my updater isn't working.  I'm not seeing a crash like you guys are, but the update fails on all devices and presents a message to contact customer support.
  • @Kaplah As @djelinek has discovered (and I can confirm it worked for me), you need to switch the date format in Windows to US to avoid the crash. You can switch it back afterwards.
  • @iVRy @Kaplah The number format issue was fixed. Please download and re-install NOLO driver from NOLO website. Sorry for the inconvenience caused.
  • I downloaded the windows 10 vm as you suggested and attempted to update 1 controller first.  It says it will try to update from version 1.0 to 2.1.  And then it fails

    https://imgur.com/a/7EnsY

    Any ideas why?
  • edited November 2017
    @admin @hettylool A week later, still no fix for missing files. I can't release update while there are files missing.



Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!