NOLO Firmware & SDK Update

2»

Comments

  • edited November 2017
    @admin @hettylool "new version sdk will update on December 6th". This is not OK. I'm waiting for the missing files to release an update. I must now wait more than another week, because someone there can't take 5 minutes to provide all of the required files for an SDK?!



  • @admin @hettylool I am really running out of patience dealing with your company. Very unprofessional.
  • This is ridiculous. Haven't had it working for 4 months and when another developer is making something that will finally work, they provide almost no support whatsoever.
  • @iVRy We haven't built the 32-bit SDK yet. It will be released along with the SDK update on December 6th as we'll need some time to test it.
  • @admin So, kinda useless release then, if the new firmware needs USB-HID SDK, and it isn't available for many weeks after the firmware update? Oh, but you say the driver was updated? You mean the one that doesn't support the velocity/acceleration values supplied by the new firmware... :/
  • Played a few rounds of Space Pirate Trainer before updating both the software & firmware.

    After the update it literally made the NoloVR markers unusable. It jitters ALL OVER THE PLACE, especially if the controllers are too close together. It didnt happen in V1 before the firmware patch. Now what do I do with it? I can't roll back can I? 
  • @edinoryazizMY It's up to the driver you're using to implement some way to ignore the Nolo IMU values. In my driver (iVRy for iOS/Android), it's possible to ignore these values unless the trigger is held down (or altogether).

    It's also possible that the SDK whatever driver you're using is built with is a version prior to this update, in which case the SDK will simulate these values (and be very jittery!).

    The whole driver/firmware/SDK situation is in a mess right now. I'd expect it to take up to another month to settle down (and everything be updated and usable).
  • @iVRy The 64-bit SDK was ready and usable before we released the new firmware, and it supports the velocity/angular velocity.
  • @edinoryazizMY Please provide us your OS, headset info and the version of software (e.g NOLO driver, RiftCat or Piplay). Our dev team will look into it. Meanwhile, could you check whether the same issue happens in the visualizer?

    Sorry for the inconvenience caused.
  • edited December 2017
    @admin Lots of bugs in that SDK & firmware. Hope the testing of the new one is more thorough.

    64 bit only is not enough. I've covered this with your developer(s) before.
  • Hi, I am trying to update firmware but it fails. now the computer does not recognize the head tracker. My Pimax VR worked fine before the update.
  • i also cant update
  • Firmware can not be updated.
    My environment is
    Windows 7 Home SP1 64 bit
    NOLO driver version 0.11

    When updating

    "Update the firmware under 64-bit Windows 10. Some updater may not work correctly on some Windows 7 computers."

    It will be displayed.
    Is it impossible to update the firmware under Windows 7 environment yet?

  • @ricardo553 @amit @koi1973 ;Please send the firmwareupdatelog under C:\Users\XXX (User name)\Documents\NOLOVR to support@nolovr.com.
  • Hi! please help! After controllers firmware upgrading to 2.1 appeared strange controllers behaviour: rotation drift around vertical axis, different hight level on floor position,  sudden controller movements... not usable at all! How to downgrade to 2.0 where was perfect?  By the way, base station and headmarker firmwares still 2.0 and FirmwareUpdate Soft  shows Up to date. Is it normal? 
  • Hello. My environment is
    Windows 10 pro 64 bit
    NOLO driver version 0.12
    After HeadsetMarker updates firmwares
    The light of orange lights up and disappears and can not be used.
  • @salo2k4 Did you upgrade the controllers with the recovery mode? Please send the firmwareupdatelog to support@nolovr.com. It's under C:\Users\XXX (User name)\Documents\NOLOVR folder.
  • edited December 2017
    @admin ; Any new on trackpad fixes? When in Steamvr, the edged of the Nolo trackpad does not reach the edge of the emulated vive trackpad, causing issues with ever shooting game that uses snap turn or edge-of-trackpad presses.

    This issue was brought up MONTHS ago, and for the most part Nolo has ignored it. Please fix it, or allow trackpad calibration.

    It is very unprofessional to leave such an outstanding issue as this and ignore your community.

    The trackapad range problem persists in both the sdk and the complete windows version.
  • +1 for trackpad calibration
    Canot run in games like onward or pavlov
  • Hi @Aureltouch , We've updated the touchpad configuration in NOLO driver 0.12 as well as in our latest windows SDK.

    All the hmds that run with NOLO driver should no longer have this issue. As for PiMax or other hmds that run with their own drivers, please wait for the software update on their side with NOLO touchpad fix. 
  • Hello,
    I have encountered similar issue with akioku
    After HeadsetMarker updates firmwares to 2.1.
    When connect  the HeadsetMarker  to PC, The light of orange lights up once and disappears and can not be used/paired.
    NOLO PC software can show Connection Status with "Hmd: connected". But now HMD can not paired with base station. 
    I have tried to perform the fw upgrade/recovery mode, but NOLO PC software always show No Conected.
    I have uninstalled the  NOLO PC software, so the firmwareupdatelog file was removed...
    Please help and thanks.
  • Additional info: I have tried to do the fw upgrade for HeadsetMarker again. The fw upgrade process was not started and  the FW upgrade tool just show  "Headset Marker firmware is up to date" Version number: 2.1.  But the HeadsetMarker  still not working/ can't be paired. 
    I also tried recovery mode, it show can't connected. It is possible that I can downgrade the FW for the HeadsetMarker?
  • solved through e-mail. thanks.
  • I have some questions regarding the new firmware. I am working to update the nolo-osvr driver that is used as part of NOFC (Nolo OSVR Fusion Configuration): 

    https://www.reddit.com/r/OSVR/comments/6uk4rd/how_to_use_nolovr_with_osvr_the_better_way_nolo/
    https://github.com/nanospork/nolo-osvr

    This driver uses the hidapi library to read data directly from the controllers and headset marker. With the new firmware I would like to add the ability to read the linear and angular velocity information and pass that up to OSVR. 

    Is there any documentation on the data format passed up from the controller and headset marker? This would be very helpful instead of trying to reverse engineer everything.  I have made some progress in trying to identify the controller velocity information. 

    I also note that, according to the definitions used by the previous author, that the firmware version in the data packets from the hardware seems unchanged before and after I upgraded the firmware (the hardware version comes back as 0x2 and the firmware version as 0x1). Is this expected? The NOLO software confirms the firmware versions as 2.0/2.1. 

    I realize that LyRobotix may have no interest in answering these questions since they distribute a binary SDK. If so, fine, I figure there is no harm in asking. 
  • I should add to the above comment/question that the reason nolo-osvr is trying to read the packets directly from the hardware is that we want a solution that will support both Windows and Linux, and there is currently no NOLO SDK for Linux. 
  • @IAmNotSpock Hi, I'm Lyuzhou from Nolo dev team. We've discussed this within Nolo, and we appreciate your efforts for making it easier for developers on all platforms. But unfortunately, data passed directly from Nolo devices are not open to the public. And we are currently focusing on mobile VR SDKs. It may take a while but we'll let you know once we decide to develop an SDK for Linux. Thanks again for your support!
  • @iVRy Hi, I'm Lyuzhou from Nolo. Sorry for catching up late. If you have further questions, you may contact us at developer@nolovr.com
  • edited January 27
    I've been quite busy so I didn't have a chance to test until now, but I wanted to confirm:
    1. The upgrade to new firmware seems to have gone great!
    2. RiftCat has a bug starting on my GearVR, but if I switch my GearVR to act like a Cardboard (app on Play store, not free sadly), it works with wired NOLO
    3. Wired NOLO crashes the NOLO software if in RiftCat/SteamVR and I double tap the "menu" button (the three line button?)
    4. Other than that, working well and even works with the Contagion: Outbreak VR demo! :)
    5. From what I can tell, the touchpad scaling might be fixed? It goes right to the edge in Steam VR home from what I see
  • edited March 24
    @admin did anyone ever fix the issue of not being able to update the firmware? I am using the latest version of the driver on Windows 10 (x64) with everything up to date, and I am getting the very unhelpful, Sorry! Update Failed Message on all devices. I was excited to try this with the new version of Riftcat this weekend, but it looks like that'll not be happening now as my Nolo devices are all stuck on 1.0 firmware. Also tried on another machine (similar setup), with no luck (same error) and tried it in recovery mode with the same error again. My (clean) FirwareUpdateLog.txt, after trying the update once is shown below.
    2018-03-24 13:27:41:nolo update process:HomePage
    2018-03-24 13:27:42:nolo update process:Init
    2018-03-24 13:27:42:update process:ConnectHidDevice
    2018-03-24 13:27:42:nolo update process:Connecting
    2018-03-24 13:27:42:nolo update conncet devices type:1
    2018-03-24 13:27:42:nolo update conncet devices hard:2
    2018-03-24 13:27:42:nolo update conncet devices soft main:1
    2018-03-24 13:27:42:nolo update conncet devices soft second:0
    2018-03-24 13:27:43:nolo update process:Connected
    2018-03-24 13:27:44:nolo update process:Checking
    2018-03-24 13:27:45:nolo update process:Checked
    2018-03-24 13:27:47:nolo update process:Updating
    2018-03-24 13:28:38:nolo update process:UpdateFail
    2018-03-24 13:29:31:nolo update process:Init
  • Ok, It turns out I am a complete idiot and it works fine, after restarting my PC. lol!! IT 101 turn it off and on again. You can disregard the support ticket I sent you.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!