still getting compositor error

I had the same issue previously, and I thought it was because I seemed to be the only one with Radeon, but I now have a gtx 1080.

Without the HDK running, the controllers are behind me. With HDK done the way the instructions say, it says "StreamVR failed to initialized for unknown reason (Error: Shared IPC Compositor Connection Failed (306))"


I can also get this error some times-
vrpn_Endpoint::getOneTCPMessage:  Can't read header (this is normal when a connection is dropped)
vrpn: TCP handling failed, dropping connection (this is normal when a connection is dropped)
vrpn: Connection request received from 127.0.0.1: 127.0.0.1 50614

(I can post a picture if you know where I should host it?)

Comments

  • edited December 2017
    Did the headset show as the 2nd monitor in the display settings? Please see if this video helps www.youtube.com/watch?v=GDgOAvza7sc.

    As for compositor error, usually it's caused by the GPU driver. Please install the lastest driver.
  • If I had an option to watch that whole painful video, or slit my wrists and chuck my nolo in the bin.... it'd be a hard choice.... but I'm trying, I'll let you know how I go
  • edited December 2017
    I GOT EXTENDED FINALLY... but currently steam still gives me the same error (and my card drivers are up to date still)
  • mousing over the small steamvr panel, everything is working but, "Base station not tracking", though it is working in visualiser etc.
    (also, I'm sorry for being so harsh on that video, but it was harder to watch than Star Trek TOS, even though it made Daley Tech's video possible)
  • edited December 2017
    Is it possible to show us an screenshot of the Steam VR status? Also you can try to plug the HDMI cable into the ports of the graghic card and make sure in the Nvidia settings the 'Preferred graphics processor' drop-down menu has 'High-performance NVidia processor' selected.
  • edited December 2017
    I never said I was good at making videos ;)
    And as you found, that's what Daley Tech's video is for, though he did miss a few bits of info.

    I was working on an Oculus DK2, so not sure what similarities or differences may come up.
    But on the DK2 I got the compositor error due to the fact I had it connected to the display port of my GPU using an active adaptor.
    It seems you needed a passive adaptor, but also your GPU must have a passive port.

    I have a EVGA GTX 1070, and even when using a passive adaptor, it did not work; so I assume these cards do not come with a passive compatible port.

    But connecting the DK2 to the HDMI port worked, and then I used the DP port with adaptor for my monitor.

    Also if you have Oculus Home installed, you need to create that batch file to disable it whilst you want to use the NOLO.

    Also uninstalling and restarting from a fresh copy of OSVR helps some people. It was one of the problems Daley Tech faced as well.

    Couple more also's :P
    1) Read the comments between me and Daley tech, some things are brought up in that that arent in the video.
    2) Such as what is the resolution of your main monitor? if its different from 1920x1080, you will need to change the x value in the render landscape file you had to copy.

    P.S. There's more than one video to watch  ;)
  • edited December 2017
    Oh and also try the beta version of SteamVR.

    Again, so many things can get in the way, hence the long boring video.
    But if you expect one quick answer to solve all your problems, it aint gonna happen.
    One thing might fix one problem, but another may come up, and then you need that one solving.

    That's why I made that video, it goes through most of the issues I had.
    Now all of this I wrote down was in the videos, only thing missing is the render file change, but that was brought up in the comments section.

    But there you go, lazy kids these days.
  • okay, I got around the trying everything mentioned over the last few days, and nothing can get it working (I even followed the entire video, and I'd already read all comments). So I'm going to letting future people googling this, know that sometimes this just can't be solved. (*I also have next to no coding skills to understand where things are going wrong)

    As a result I'm passing it on to a friend who should be able to use it like 99% of the rest of the world.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!