[THREAD] Trinus PSVR Crashing

As we all have a problem with Trinus crashing when using NOLO ASSISTANT with headtracking + TrinusPSVR, I did a thread so we can all talk about it here instead of creating a lot of little threads....


So for now, we can't play without crashing at a moment with a PSVR and Nolo because of this...

We have to wait for Trinus OR Nolo to update the way it manage the communications between each over...

BUT, I haven't tried yet, it seems that using the old Nolo drivers instead of NOLO ASSISTANT works perfectly fine.
BUT YOU SHOULDN'T HAVE UPDATED YOUR CONTROLLER TO 2.3 !
Or some functions will not work properly...

If you didn't updated through NOLO HOME, you should be ready to try this temporary solution, but remember that it's old drivers and so... it will not be as great as before...

Here's the link of the old drivers, give a try or wait ;)
https://github.com/NOLOVR/NOLO-Driver-For-Windows

Comments

  • How do you tell what version the controller firmware is?  Nolo assistant says 1.1.18 but I think that’s the version of assistant.  Can the firmware be downgraded?
  • edited December 2018
    Looks like NOLO ASSISTANT have nothing to show the hardware firmware, or maybe when a new firmware will be available ?

    For now, only the old driver can use a hardware update manually (it will told you your current firmware and update available), and NOLO HOME

    If you never did any of it, you should be fine, but worth the try, the worst could happen is that you should uninstall these drivers easilly, and install NOLO ASSISTANT again

    As I don't know what version start to create problem, I'll not try to update...
    Does someone tell us what firmware start to create incompatibility with PSVR ?

    ALSO, I just bought my NOLO VR, and my headset marker is up to 2.1 and the old nolo driver tell me that everything is up to date ;)
    for me:
    headset marker : 2.1
    Controllers : 2.2
    Base station : 2.1


    Sooo, I think these are the last to make it compatible for now
  • I think I did an update with nolo home just before the 1.8.17 version came out.

    i thought nolo home was not for use with trinuspsvr?

    if I load up nolo home will it tell me my firmware versions without changing things?

  • Yeah, Home isn't for PSVR of course, certainly that's why only HOME have the 2.3 hardware update that break the nolo assistant functionality.

    Well, with the old drivers, it say to me the currentn version, and the update available, and I think Home do the same ^^
  • Said nothing, in my version, trackpad don't work like that... please... -_-
  • @cyberkevin Thanks for creating this post. We received many inquiries about the crash issue. Our dev team is checking NOLO assistant and try to find out the reason why Trinus crashes. If we have any update, we will update here. If anyone would like to downgrade their firmware (update firmware mistakenly), please contact us at support@nolovr.com. Our engineer will book a remote session for you to downgrade the firmware. 
  • Looks like on the reddit someone have a solution, and I tried myself something

    So I tried executing both NOLO ASSISTANT and TrinusPSVR as Admin, and it was stable for the last 30 minutes of gameplay I had before sleeing, so I don't know if it will crash soon or not...

    Still,  someone said that he resolved it by saying to the AntiVirus to ignore the folders of NOLO and STEAM VR (I added the TrinusPSVR folder too, but haven't tried yet if it works)

    Reddit Link : https://www.reddit.com/r/PSVRHack/comments/a9l76h/trinus_psvr_keeps_crashing_with_nolo/
  • I was running NOLO ASSISTANT and TrinusPSVR (and steam) as admin when I was testing yesterday and it did not solve the problem.  Whatever causes the crash seems kinda random, I've had it stay up for anywhere from 20 minutes to less than 1.

  • edited December 2018
    @Greg_Corson well, worth the try, so it was pure luck x)

    Still, the developer of TrinusPSVR know that there's a problem and will work on it soon...
    Haven't tried yet for the antivirus thing :/

    Also, here are my reports on the crash did with my debugger...

    https://ibb.co/FBcCqJf

    https://ibb.co/8MpK93d

  • I tried the newer Trinus test release but it seems to have NOLO disabled, the checkboxes to turn it on are gone.

    Please guys, sort this out.  The Trinus dev says he hasn't been contacted by NOLO and NOLO says they have tried to contact Trinus but no reply.  
  • @Greg_Corson ;Nolo contacted Trinus the wrong way, of course he didn't reply, still he know everything about it and will work on it, personally, I think NOLO have to work on it, as they have published an untested compatibility update and broke by itself the compatibility :/

    It should be the priority of NOLO right now -_-
    But seems like it's more easy to ask the other to work to correct their mistakes :/
    I'm really not proud of Nolo right there...

    @admin
  • Hmm... well...
    I dont know what happened, but I done a REALLY GREAT setup right now '-'

    To be honest, I was really angry on Nolo, cause sudendly, Nolo Assistant don't work anymore !
    WHY ? WHAT THE FUCK ?
    I wait for answers from Nolo. -_-

    Still, I wanted to try something : 

    I uninstalled Nolo HOME, reinstalled the last version of Nolo Assistant, and Installed the last Old Driver of Nolo, even if I knew that track pad isn't working like that :/ 

    .... Then... I try... Well... everything is working... '-'
    (Nolo Assistant -> Crash but on process still running -> executing Steam VR (not working) -> Old Nolo -> Working WITH TRACKPAD )
    And of course, No Crash with Old NOLO software '-'

    Sooo, I don't know why, but that way, everything is working...

    EXCEPT THAT NOLO ASSISTANT DON'T LAUNCH ANYMORE ON ANY VERSION ! -_-
  • @cyberkevin

    Does SteamVR work at all? Otherwise it's pointless
  • edited December 2018
    @Seether00 everything is working ;)

    Here is the installation order I did~
    https://i.ibb.co/7pxjznD/001.jpg


  • @cyberkevin

    So I tried that and the controllers now show up in VR(shocking) but they show up to the left, right or behind me. Doesn't matter how I try to reset them. Or recalibrate the headset. 

    Then Trinus PSVR crashes after a few minutes anyway. 

    Sigh. Thanks for the tips though. 
  • @Seether00 The thing with the controllers showing up behind you is what happens for me if I use Trinus with NOLO head tracking turned off (in trinus).  So it's using the PSVR tracker for the head, not NOLO.  No idea how to make them line up.

    Honestly, getting annoyed that neither Trinus or NOLO have said anything about fixing this for a good 4 days.
  • edited December 2018
    @Greg_Corson the Trinus dev said he will do it, but hey guys, be cool, it's holidays, just wait a little -_- 

    Also, I don't know how I managed to make everything working with old NOLO + TrinusPSVR 0.9.8b, but loks like there's a way :/ 

    So once again, you can try to uninstall everything, then install in the order (down to up) of my screenshot up there, executing TrinusPSVR, then NOLO ASSISTANT (for me, it crash directly, so close it after that maybe, I don't know... just trying because I don't know how SteamVR manage what Driver to use), then Steam VR, then NOLO, and see :/ 

    Just remind that now I restarted my computer, I just launched Trinus, then NOLO, then SteamVR, and everything is working :/ 
  • @Greg_Corson not sure which setting your are talking about. I believe have all the Nolo checkboxs in enable in TrinusPSVR. 

    Including the Use NOLO forward position which some have said is bad. I'll recheck when I get home. 

    @cyberkevin Yes it's the holidays. I'll wait until Jan 2 or 3rd but I'm a new customer and to not have it work brand new makes me questions my purchase. 

    I believe some of you have had this product for a while and it worked for you before recent updates so my frustration is different as I've never seen it work as advertised. 
  • @Seetther00, it was my Christmas present ^^
    I know how you feel, but still, this hardware is really great, if we have software problems, it will be solved for sure at a moment...
    Specially when it's just a little compatibility issue ^^

    I found that there's a way to make it work without missing any functionality and said how I did it to help, hope it could help someone :/
    To be honest, when I saw everything is working, it felt like I did something wrong to make it work xD

    I just know that all drivers are installed at that moment : old and new, and steamVR seems to have the correct way to interpret it with the old Nolo software running :/
  • @admin

    Is there any update on this issue?
  • I tried loading up the old NOLO driver as shown above but it does not work correctly either.  Starting the old driver it shows connected to the HMD and controllers but not the base station.  When I start everything up with Trinus the headset tracks and both controllers track in X, Y and Z but they do not rotate.  Any suggestions on how to get it working or do I just need to wait for your fix?
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!