Can anyone help me with using Nolo with generic HMD

Hi. I have a Direk-tek (aka VR--tek) WVR3. Its a generic Windows HMD from China (NOT mixed reality) I purchased for cheap. I had some driver issues getting it to work, but now it is working great with Steam VR and Xbox conntroller! I want to try to use this with the Nolo I have to get 6 dof tracking. The headset is not Android base so I can't use Riftcat. Actually I don't think this HMD has an OS. I think the Nolo client only has Gear VR and Oculus Go listed.

Can anyone provide a method to get Steam VR recognize the Nolo for generic HMD with built-in display not running on Andriod/other form of OS? Maybe OSVR or Oculus DK method would work? Thank you!

Comments

  • Hi, the old NOLO Home version has a "PC Headsets" option that you can try (If you can find an old biuld of NOLO Home).



    But first, try to use the NOLO Assistant app (wich is the easiest way to achieve what you want, I think) The only thing with this app is that I don't know how to update the hardware firmware otherwise It works really well:

    http://img.nolovr.com:8000/NoloAssistant/NOLOASSISTANT_Setup1.1.11.exe


    NOLO Assistant is just a driver setting software and don't have any streaming option, it was meant to be used with Riftcat for android users or Tritus for PSVR users (it's basically NOLO Home without the ALVR integrated streaming software) and there is an "other" option in the headset configuration selection that is used for OSVR headset and DK2. Lots of DK2 users used the Assistant to play SteamVR with NOLO and their DK2 so I know it works. (never tried it but other made it worked so I think it' working  :) )



    Here is the link of the user guide for DK2 (you also have the one for OSVR on left under the DK2 one in the sections list), I think you can use it as a reference to try to configure your Headset with the old NOLO Home App as well (if you can still find it online but try NOLO Assistant first):

    https://www.nolovr.com/ocdk2?treeid=tutorial_2_9

    The very last resort is to try Driver4VR wich can make run averything with anything (seriously ! Kinects with VIVE, Oculus, WMR, Android device, Apple device, with joycons, Psmoves, Android controllers, Draydreams controllers, Wiimotes AND finally NOLO VR) BUT the driver used for NOLO VR needs a LOT of configuration and is not has stable as the one provided by NOLO (the dev of Driver4VR doesn't copy drivers, he make his own one so it may differ from the original one). You have 7 days free for try it but the software cost ~20$ wich it worth the money compared of what it is capable of (sale 20% off at 15$ for now). The little plus is that the dev answer to questions by email really fast (just like our beloved admin here  :p )

    https://www.driver4vr.com/


    Sorry for REALLY long post and I wish you good luck in your journey to acquire a full SteamVR experience adventurer !   B)
  • edited January 12
    @mrxkuul Can you say if it works or not ? I'm kind of curious about it.

    btw I saw youtube comments of someone that made the same headset you have works with Driver4Vr for 6 DOF controls so I think it can work with NOLO as well (or using Driver4Vr to make NOLO works)
  • Yes this works, but....the left controller buttons do not work. The tracking is decent and I was able to play Beat Saber okay. There is a 0.2-0.5 second lag, but once you get used to it, its enjoyable.

    The only thing is that my left controller buttons do not register. It works in the Nolo Assistant visualizer and the plain white VR screen, but it does not work in Steam VR Home nor in any game for that matter. Luckly Beat Saber doesnt need any left controller button presses, but I have tried several other games such as Arizona Sunshine, but no go.

     I used the Nolo Assistant v 1.1.18

    If you know a fix for this it would be greatly appreciated. Thank you!
  • By the way I also had to repair my base station once with the repair tool because the tracking was inverted. This fixed the tracking issue, but buttons do not register in game.
  • It can be something wrong with all the driver you use (or tried to use) on SteamVR. I had "similar" issues with my button when I tried to mix up Driver4VR and NOLO Assistant only the menu button worked on both controllers but everything looked good in the visualizer) NOLO Support provided me a solution.

    They said to me to : enter %localappdata% to the address bar of windows file explorer, press enter, it will directly link you to a folder named "Local". Find "openvr" folder under it and you will find the file "openvrpaths.vrpath" there.



    After this they said to modify this file with the Notepad. Basicaly just delete everything between the lines with blue arrows (or the red square, you choose  :p ) than restart your computer, relaunch SteamVR and try.

    /!\ WARNING /!\ : It may break something with your drivers setup, try this at your one risk. If you are not sure about this solution try to reach the NOLO support team here: support@nolovr.com with a detailed email about your problem. They usualy answer quickly to emails (If not send a message to the admin)
  • @mrxkuul Hi, thanks for your message. We received your message and replied to it. At this stage, NOLO CV1 is not compatible with Direk-tek (aka VR--tek) WVR3. 
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!