Nolo assistant doesn't recognize the base station or controllers

I am attempting to get my nolo setup working with my DK2 and Driver4VR as opposed to OSVR.

Now Nolo assistant wont recognize my base station or controllers despite showing green paired lights all round.

I have updated firmware on all parts and was wondering whether this might be the problem,

I have had this VR setup for almost 6 months and Nolo has never worked from the beginning. Please can you help me fix this situation as it should be completely compatible with my existing hardware.

Comments

  • In nolo wisdom they have yet to update the nolo assistant to be compatible with the latest firmware. As annoying as it is, use the nolo home with the new firmware. If you want to use it in steamvr you can launch the home after launching steamvr so that it does not take over steamvr.
  • Ty Observer but what is Nolo Home and why do we have Nolo assistant AND Nolo Home...I'm confused.
  • @siege, you can get the Nolo Home from their main website. It now appears to be their all in one application for using your mobile setup for vr. The assistant was the updated version of the old windows driver which allowed for easier use with steamvr. 

    They updated the device firmware and nolo home but appeared to have abandoned the assistant even though I have been told it will be updated. The summary of it all is if you update your firmware you are currently forced to use the nolo home even though the assistant would generally be better because we do not need all of the extra stuff running just to get steamvr compatibility.
  • @observer Thanks again for your input. Like you said,  I am having to use Nolo Home due to firmware update however,  Nolo have offered to rollback firmware for me. Would you suggest going for a firmware rollback or wait for updated Nolo Assistant?
  • @siege, I am not exactly sure what your full setup involves but you will probably want the latest firmware due to the better tracking. 
  • @observer, You're a top man! I have a DK2+Nolo setup as per the following guide:

    https://www.driver4vr.com/forums/topic/updated-dk2-nolo-tutorial/

    I have yet to try it without the DK2 sensor as there seems to be a clash of software resulting in erratic hand movements i.e Beat Sabre. Any suggestions would be greatly appreciated.

    All the best

    Siege
  • Oh btw, I'm using Driver4VR also...
  • @siege, what version of driver4vr are you using? Read the version number from the top left of the application window.
  • 4.8.0.2 Beta
  • @observer, FYI I only managed to get this setup working in the past 2 days...fine tuning now thanks to your input
  • @siege, you could try grabbing the driver4vr test build from the discord announcements channel. that version should be 4.9.0.6, it has some experimental changes to nolo hand tracking. That might help with tracking stability but there may be some hand tracking bugs for driver4vr hand tracking with nolo as it will only be fixed after the kinect stuff that is being worked on is done. Are you sure its not just the sensors clashing or are you positive its some sort of software issue because then you should probably either ask around for help with driver4vr on the discord/forum or send a support email directly.

    If you have it all good now that is great to hear, if its still freaking out then you need to be sure its a software or hardware issue first to get the correct help.
  • @observer, Have since tried setup without DK2 sensor and things are much improved. As you said and I attempted to say, the DK2 sensor was conflicting with the base station. 

    Thanks for the heads up with regard to latest Driver4VR version, I'll be sure to add to my discord.

    Cheers for your help observer. If you hadn't pointed out the difference between Nolo Assistant and Nolo Home, I might still be trying to get this thing to work!!!
  • @observer, I see there is a driver4vr version 5.0 that addresses specific Nolo issues. Should I download that one?
  • @siege, you can try any version of driver4vr you want. 5.0 is not out yet as far as I know they are still test builds. As they are test builds if you need a previous version there is a link somewhere in the general faq on the discord under the description of if a new version does not work properly.
  • @observer, You've been a great help and I see that you do the same on discord. Power to you! Just a few more questions if I might. Do Nolo Assistant and Nolo Home install to the same directory? I'm using Nolo Home but Nolo Assistant desktop shortcut still exists despite there being no Nolo assistant in control Panel Add/Remove programs and if I double click it it opens Nolo Assistant but will then crash.

    Also, do I need to purge previous Driver4Vr installs before running a new build? On discord someone was talking about %localappdata% and deleting Greg's folder. Is this the case?
  • edited May 12
    @siege, the two applications, assistant and home, should install in a different folder. I am not sure what you did but you should try looking for where you installed the assistant to see if it is still there. You can also try looking from the shortcut properties to see where it links to, if perhaps you do not remember where you installed it. Alternatively if the nolo assistant driver is still registered with steamvr you can open the file at [%UserProfile%\AppData\Local\openvr] with a text editor to see the install location and to remove the driver manually if you are unable to automatically uninstall. Also do not run multiple nolo software applications at the same time they will conflict.

    No you do not need to delete the appdata, but I do recommend uninstalling before installing a new or older version. Only if the installation gets corrupt trying to read older config data was the reason that suggestion still exists. It is not a very common issue these days as far as I am aware.
  • @observer, Cheers! Would you mind looking at my screenshot and you will see that Nolo Home is in fact installed inside Nolo Assistant directory. I have no idea how this may have happened and am reluctant to fix it if it ain't broke if you know what I mean...wait, how to attach a screenshot???
  • Observer,  I uninstalled and reinstalled Nolo Home and now there is no trace of Nolo  Assistant. I also uninstalled drver4vr before updating to the 4.9.0.6 build. I've paired all devices in Nolo Home but when I start driver4vr it says IPC error and steam won't initialize...what have I done?!   :'(

  • @siege, we can continue this conversation on discord if you would like because I will probably need to look at the log files. As long as its not DK2 specific I can try helping you troubleshoot some things. First thing to do would be to send me screenshots of driver4vr main window and steamvr status window.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!