problems with Riftcat untethered

I have just tried to use the beta version of riftcat that gives you the untethered option. I may be doing something wrong but I don't seem to have any tracking at all. the strange thing is, i managed to get it working once, but is was just rotational, so just from the phone sensors. when it worked, I could not get the controllers to be recognized and when it doesn't work (no tracking) the controllers are recognized but keep taking screen shots or bringing up the menu without  me touching them.. 

bigelowed uses and recommends this setup, so any help would be appreciated. 


  • First of all, remember that you don't use the nolo app at all, so keep it close.
    Also, did you changed in the riftcat app the tracking options to cellphone exlcusive?
    You are using the GearVR version or the normal version?
  • @Tux0Topo nolo app is closed, changed tracking options to phone only and it's the normal version.. 
  • ok, well i managed to get it working.. however it was taking screenshots every couple of seconds and bringing up the menu without me actually pressing any buttons, so completely unusable. I have read that other people are having this problem, but others seem to be able to use it.. Is it a case that the gear vr version is more stable or is there a way to stop these random phantom button presses? 
  • edited September 2017
    Do you have VirtualHere installed on your phone? Some people have commented that they fixed the random screenshots issue by uninstalling VirtualHere.
  • @Zomby i also read that, but nope, i had it but uninstalled it a while before trying this.. and i have nothing similar that might be affecting the usb port.. thanks for the suggestion though. 
  • Phone  model or headset type? Is it screenshotting on the phone or the desktop?
  • @bigelowed hi, phone is xiaomi redmi note 3 pro and headset is bobo vr z4, it's doing the screen shot through Steam. Do you have this problem at all? 
  • Hmm, I haven't had the screenshotting no, but it looks like it thinks your system button and right trigger are held at the same time:

  • Riftcat are aware of the problem and will be trying to address it in the next update hopefully with ceiling mount capability
  • @bigelowed @AxleB thanks, i actually have other issues with my controllers (no haptic feedback) they are being returned tomorrow.  So hopefully this will be fixed when i get the replacement controllers. 
  • edited September 2017
    Do they vibrate when they turn on? RiftCat wireless has no vibration right now, but the controllers themselves should work if using the classic NOLO software.
  • @bigelowed Yeah they do vibrate when i turn them on, but nothing else after that and not just using riftcat untethered. Lyrobotix have tried doing a number of fixes on then without any joy. so they have asked me to return them to them.
  • Ah then yeah, that's fair then, I just was worried you were only using untethered which does not have vibration yet.
  • @belly I'm having exactly the same problem as you with the screenshots, menu, and not get 360 turn to work, I kind of thought it was just the riftcat software not being quite there yet, but what I found interesting here is My phone is also a RedMi Note 3 Pro, so I would be curious to know what Rom you are using, I'm using Nitrogen OS and was thinking it may be an issue with one of it's settings.
  • @alec100_94 The thought had also occurred to me, I'm currently using MIUI 9 Global 7.9.7 developer version. It has just updated to MIUI 9 and i can't remember if I updated it before I sent my controllers back.. but I definitely had the problem with MIUI 8, my wife also has the same phone but with the stable rom version. So when I get my controllers back, I will have a play around with different versions and possibly different phones.. I would probably suggest that it would be a good idea if you can get your hands on another phone to try and then you hopefully can rule out the Nolo hardware... 
  • I'm pretty sure my Nolo controllers are fine, as I played with them for quite a while in tethered mode with no real problems (everything worked). It sounds like it's not the ROM either as NitrogenOS is essentially a modified version of LineageOS (Previously CyanongenMod), which is about as far away as you can get from stock/Dev MIUI. So it must be some hardware in the RedMi Note 3 Pro, making it act oddly, which is ashame as this is the phone I intend to use with it, hopefully it can get fixed in the future. Though I will try with another phone when I get the chance.
  • Just thinking what different things can affect the usb.. do you have debugging enabled or disabled? 
  • I just tried experimenting again, with developer options completely disabled and same result. Also tried different tracking modes (Google Default, Magnetometer, etc.) and the same thing happens. It does seem like a really weird problem, and makes no sense why it's isolated to the RedMi Note 3 Pro.
  • I don't think it is just the redmi note 3, I'm sure I've seen other people having the same problem with different phones, but maybe just not as bad.. i think that there could be other factors causing problems as well, possibly something installed on the pc, either a program or driver for example. As soon as i get some spare time I'm going to try to a clean pc install and clean phone setup and see if that helps the situation.. 
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!