Oculus DK2 using github instructions

Followed these instructions and OSVR server will not run

https://github.com/NOLOVR/NOLO-Others/tree/master/NOLO_Oculus_Steamvr
«1

Comments

  • If you havent realised by now, NOLO have added their own set of instructions for the Oculus DK2

    https://github.com/NOLOVR/NOLO-Others/tree/master/NOLO_Oculus_Steamvr
  • I have the same issue, and I'm slowly trading emails... I'm a little sad, because I was so excited to be one of the first to get one, but one of the last to use  :(
  • Oh? I have it working using the link NOLO have.

    Do you have more than one monitor? As the instructions are based on you having only 1 monitor.
  • only my monitor and the dk2 are attached
  • is it okay to attach the head marker to the dk2's usb? it's getting powered and everything seems to be working. I always try it, and my PC, but I haven't noticed anything different, how about you?
  • edited June 2017
    I tried to attach the marker to the dk2 usb port, it didnt power up at all.

    Oh wait, in order for it to work you need to use the power plug, not enough power using usb and hdmi alone.
  • I know that, I found their new video that explanes things in completely different ways.... I have made it further now, but I'm stopped on a, "launch compositor" error in steamvr
  • edited June 2017
    Is your DK2 plugged directly into the graphics card or are you using an adaptor? Like have you got a display port to hdmi adaptor to plug in the DK2? Like this one http://www.ebay.co.uk/itm/Display-Port-DP-Male-To-HDMI-Female-Flat-Adapter-Connector-Converter-for-HDTV-PC-/351368778384?epid=562360603&hash=item51cf361290:g:92YAAOSw2s1UvP7U

    If so plug your monitor into the adaptor. You need your DK2 plugged directly into the graphics card.

    If you use an adaptor it need to be a passive adaptor, not an active one.
  • Are you running the beta version of SteamVR?

    The DK2 will only work with the beta version
  • edited June 2017
    Even though I can not find anything written suggesting that, I checked anyway, and it still comes up with the same error, saying that the base station is not tracking.
    when moused over the "R" it says;
    "Base station not tracking
    This base station is powered but not tracking. Make sure it is visible from your headset, or a controller."
    I've even held it right in front of the tracker, and nothing.
    I also have a new issue, it takes about 20 times to get the nolo program to stay open, because it will just turn off after a second most of the time.
  • Hello, another problem I do not know where I was wrong I did all the instructions for dk2 but in the viewer i only see the black screen does not work can you help me?
  • edited June 2017
    I uninstalled everything from Oculus, the server OSVR starts but on the PC display you see but in the viewer no
  • Phillip: I also have trouble getting Nolo to start sometimes (not using DK2). Maybe I am imagining it, but it feels like it is easier to get Nolo to run if I wait 10 seconds between re-running Nolo (after it crashes).
  • vincerex: I read somewhere that you should have the windows on top of each other to make it stream properly to the HMD. But I don't have an Oculus so I am just speculating here.
  • Run NOLO in Windows 7 or 8 compatibility mode. It has issues with Windows 10 for some reason.

    Again for the black screen, are you using an adaptor to connect the DK2 to your graphics card? If so it needs to be a passive adaptor, not connected directly to the graphics card.
  • "the server OSVR starts but on the PC display you see but in the viewer no"

    What do you mean by this?
    Are you running dual monitor? and the game appears on your second monitor?
  • it's directly connected to the HDMI on my graphics card, upon playing with the setting for a few hours, the issue seems to be that the HDK software won't display on my DK2's screen.

    As for Nolo constantly crashing, running it in comparability win8 mode fixed everything, and didn't stop it from working in any way.
  • Thanks for the tips I tried everything but it still does not work
    this night i try to uninstall everything i try again
    i have connected the hdmi cable directly to gtx970 but it does not go.
    Is really complicate!
  • When you run the OSVR server, do it like it's been done in this video.

    You need to select a new configuration, so do this after copying all the files NOLO instructions tell you to copy.

    Then right click HDK Tray icon and select HDK Configuration, then Options then Custom, and then select the newly copied over osvr_server_config.json

    Then start Steam VR and let us know if it connects




  • edited July 2017
    I already found that one and tried it. I can use the "Oculus_Rift_DK2.json" and get it to work on my monitor, but no .json file will make anything display on the HMD, not even delving into playing with editing json files and using extended mode.

    I'd like a poll done, does Nolo always work for Nvidia, and never for Radeon?
  • @Phillip Is there any error message in server window after running osvr server? Did you type "xPosition" in renderManager.extended.landscape.json to match your monitor?
  • only the errors that I posted before, and I tried that xposition to no avail. It seems the OSVR program has no access to my DK2.
    When a screen turns on, but displays black, you can usually still see it, but the DK2 screen doesn't turn on.

    I'm also still wondering if this is a Nvidia vs Radeon issue, please all answer
  • edited July 2017
    @Phillip, Right click on your desktop and select Display settings with your DK2 connected.

    Does it show one monitor or two?

    If you have one monitor it should show 2, your monitor and your DK2.

    Your monitor should be on the left, and the DK2 to the right of your first monitor.

    Click on your monitor, usually 1, and scroll down to where it says Multiple Displays
    The drop down should be set to Extend these displays with the Make this my primary display box ticked
    Click on your DK2, should be 2, and do the same but leave the Make this my primary display box  unchecked. ALSO set the orientation of the DK2 to Landscape.

    Note it doesnt matter if your monitor is number 2, or 1, just make sure your the DK2 is to the right of you main display.
    So if you have 2 monitors and the DK2, the DK2 goes in the middle.
    If you have 3 monitors, you have your main display to the left, then the DK2 to the right of it, then your other 2 monitors after the DK2.

    Then retry the startup as in the video above.
  • nope, it works as a device, and it seems that only the oculus software can access. I could try old oculus runtime versions, but they were vomit inducing after short amounts of time.

    I'm also still wondering if this is a Nvidia vs Radeon issue, please all answer
  • Then that is your issue, you need to have the DK2 appear as a monitor when you go to Display Settings.

    Try a different port, or update your GPU drivers.
  • I take it that you don't have a DK2?
  • edited July 2017
    I have a DK2, that's why I am telling you, if the DK2 doesnt appear in the monitor list, then it wont work.

    Also right click the OSVR icon and select Enable Extended Mode just to be sure. then run OSVR server then see if the DK2 appears.

    I have a NVidia card, so I cannot say if it is your Radeon card or not.
    All I can say now is first get your DK2 to appear on that monitor list, how, you'll have to figure that out and google DK2 and Radeon.

    I can only tell you the problems I ran into with my DK2 before getting it working. and I think I've listed all of it here now.
  • edited July 2017
    --
  • This may not be the thread for me, I believe this is a Radeon issue then.

    Under no circumstances can I get my DK2 to work as extended monitor. I will try previous oculus runtimes later. Thanks for your help though
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!