#NOLOupdate NOLO HOME version 1.20 released!!!

edited November 2020 in General
1. Solved the problem of freezing while streaming by some HUAWEI VR Glass users using wired mode.
2. Optimized streaming dynamic bit rate algorithm to make dynamic bit rate more effective. 
3. Added the downloading reminder to remind users to pause download before connecting. 
4. Solved some known issues. 


  • What were the known issues you solved?
  • Please solve tracking of controllers after loosing the visibility. It takes way too long, not 20ms, not even 200ms.
  • My high end Sapphire R9 290x Tri-OC shows up as R9 200 series in your app and you still did not solve it. It tells me that GPU does not meet the requirements.
  • Your app is updating version 1.20.16 to 1.20.16: https://1drv.ms/u/s!Aq5X0D4OWWAThJAQVBq-deUfdg7f_Q

    Anyway it says updating NoloDevice.dll, does it mean we /developers/ will get updated SDK https://github.com/NOLOVR/NoloDeviceSDK ?

    After updating head tracker + base station is online and head tracker change led from red to green. But your app still shows that it is disconnected. Before update, it worked.

  • Head tracker over USB not being recognized by Nolo Home after this update: https://1drv.ms/u/s!Aq5X0D4OWWAThJARKkjz4Y_mD_oSlg?e=8N71HN
  • Reverting back to 1.19.10 works and head tracker says connected in Nolo Home. You tested only with HUAWEI and you new USB check requires both phone and head tracker active over the cable, right? That sounds like new bug you introduced.

    Whole part of Europe and USA cannot buy Huawei.
  • (would be cool to have option to disable your automatic updates if it contains serious bugs)
  • Today you change version from 1.20.16 to 1.20.17 and it still does not detect the head tracker!!! Perfect release!
  • Nolo head tracker is identified as Nolo Controller 1 in Nolo Home, connect/disconnect reacts on that USB cable. How smart and convinient.
  • 2020-08-22 20:36:38,546 PID:17148 ThreadId:[1] INFO  NOLO_HOME.UserBoot 行号:534  - 本机显卡是amd版本号27.20.2001.13001  
    2020-08-22 20:37:09,647 PID:17148 ThreadId:[1] INFO  NOLO_HOME.CoreFiles.NoloManager 行号:41  - lost data timer tick  
    2020-08-22 20:37:09,647 PID:17148 ThreadId:[1] INFO  NOLO_HOME.CoreFiles.NoloManager 行号:42  - 数据丢失了!!!  
    2020-08-22 20:38:24,523 PID:17148 ThreadId:[1] INFO  NOLO_HOME.DevStatusControl 行号:384  - eLeftController-----V0.0.0  
    2020-08-22 20:38:25,671 PID:17148 ThreadId:[1] INFO  NOLO_HOME.DevStatusControl 行号:384  - eLeftController-----V0.0.0  

  •  2020-08-22 20:30:27,936
    [16] (C:\Users\nolotest\Desktop\Git\NoloHomeNavigation\Nolo_WPFAssistant\Common\LogHelper.cs:51) 
    System.Net.Sockets.SocketException (0x80004005): A blocking operation was interrupted by a call to WSACancelBlockingCall
       at System.Net.Sockets.Socket.ReceiveFrom(Byte[] buffer, Int32 offset, Int32 size, SocketFlags socketFlags, EndPoint& remoteEP)
       at System.Net.Sockets.UdpClient.Receive(IPEndPoint& remoteEP)
       at NOLO_HOME.RemoteDisplay.ALVRListener.ReceiveUdpMsg(Object obj) in C:\Users\nolotest\Desktop\Git\NoloHomeNavigation\Nolo_WPFAssistant\RemoteDisplay\ALVRListener.cs:line 435

  • R9 290x is hardly high end by today's standard. You do realize that card is 7 years old, right? PC VR as we know it today was still in early development. 
  • @cyberluke
    Thanks for your messages. 
    1. for the tracking latency, we think the setup of your devices may be wrong. Or the device is too old. Could you provide the serial number of your NOLO CV1 which shows on the product box starts with LY words?
    2. For the graphic cards, we didn't buy all the graphics cards to test. So if you close the user guide, and you can start the streaming service from the NOLO HOME main page, then it should work. We appreciate that you let us know the graphics cards model, so we could add it to the white list.
    3. For the SDK, we have already provided you via email. We will update the latest version to Github soon.
    4. Once you update the firmware of your NOLO devices, please make sure to re-pair them before use.
    5. For the 1.20 version that NOLO HOME windows client doesn't recognize your headset marker, we have already found this bug and will update it in the next version. It shows wrong, but you can use it. (We could send you the file and you could replace it in the relevant folder to fix it.)
    6. For the automatic updates, currently, we don't have the plan to turn it off. But I have forwarded your suggestion to the dev team.
    7. We don't just test Huawei devices. We test all the VR headset that we support. 
    8. For the two error logs: The 1st one is due to that NOLO HOME didn't receive any data within 2 seconds, then it will show this error. The 2nd one, we will fix it in the next version.

  • Thank you, my Nolo devices are brand new. All cables were packed in sealed plastic packaging. I think that's the most of my problems. I'm solving it with e-mail support now. Thank you for detailed answers and great support so far!
  • @cyberluke
    Thanks for your update  :)
  • So two months later this bug is still not fixed?!?

    The only version I can find to download is v 1.20.17, from August, which has this bug.

  • @chjohans
    Hi, the current version is 1.20.18. May I know what bug did you mention?
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!