Pimax 4k+Latest Pitool not detecting Base Station

Do I need to update Nolo's firmware in order to run latest Pitool and have it detect Base Station?

I am currently running PiTool with original Nolo firmware and although things are working, I would like to use latest PiTool software and updated Nolo firmware.

Am I ok to upgrade Nolo firmware?




  • same problem here, how fix this please
  • For information Pimax don't suport nolo now !!!!

    This is a link of archived piplay :

    i create an topic on the pimax forum here :  https://community.openmr.ai/t/pitool-firmware-links/26733

    don"t exepte support or update :'(

  • OK i have false
    So Pimax not support piplay but only Pitools

    and with the latest Pitools that's workks  u have it here  :

  • Merci Pimax_fr
  • edited December 2020
    @siege so i got big issue, so i got the controlleur on my headset and i can move it in the 3D space ??

    and when i move in the 3D the same not working, my full body not move in the 3D workd

    i think tracking not working

    @siege par contre j'ai un gros problème j'ai le tracking qui ne marche pas

    quand je me léve ou bouge la tête il n'y a pas de tracking des manettes ou de la tete :/

    mes menttes tourner mais sont collé à ma tête et impossible de les déplacer dans le monde 3D

    je ne comprend pas ce qu'il se passe :/

    j'ai reinitaliser tout mais ça veux rien savoir

  • Can you read my other posts? "...90% Aggravation..."

    I managed to update Nolo Firmware using latest Nolo Home but if I download latest PiTool update ( from the PiTool settings menu, I lose all usability as far as Nolo is concerned, despite it showing movement in Nolo visualizer.

    Reverting to PiTool rmemdied the problem. I did read somewhere that another Nolo user had to delete all trace of Nolo AFTER firmware update in order for Nolo and latest version of PiTool to work but as yet, I haven't had the guts to try it.

    Obviously PiTool MUST be the latest version but I'm still very confused.

    Let me know how you get on.

    All the best

  • Je suis Escosse btw
  • Have you updated Nolo firmware?

  • i don't know

    do u know how see the name of the firmware ?
  • ok i found this my version  of nolovr  :


    so how now is the old one or a new one ?


  • What verion of Nolo Home are you running?

  • Pimax_fr, I want to help but am having trouble uploading images. Can you help?

  • My Pimax, Nolo setup works great...after alot of tweaking, however, I am still unable to run using both products latest software version.

    I suggest you download latest Nolo Home, Update Firmware via Nolo Home Maintenance Menu.

    Delete current PiToll and ALL traces of PiTool AND

    Install PiTool OR

    Removing all traces of PiTool is problematic therefore you need to show all Files/Folder and enter %AppData% one by one until all traces are gone. Thats what worked for me.

    Good Luck!

  • to upluad and image the best free tools is : https://getsharex.com/
    nolo forum don't accepte upluad picture

    if u want come talk with me on my discord dedicated to the old pimax4k :

    ok i try what u says and i told u


  • After hour and hour to try, to install reinstall

    my headset tracking WORKS !!!!

    But my controlleur not work, i can't see them on the 3D view  :

    what i do

    i remove evrything

    1/ I install pitools last version 2.66
    2/ i install nolovr on steam
    3/ i start steamvr, because from nolo the headset is not found
    But the hedset works and the tracking to

    BUT BUT BUT the controlleur don't want to show them :

    last step !!!

  • Pimax_fr

    Make sure Nolo Home is turned off. Set PiTool to load on start up and restart your computer. Never have Nolo Home running alongside PiTool or it will conflict.

    You might want to uninstall Nolo Home once all Nolo firmware is updated and consider downloading latest PiTool from settings menu.

    I was advised by Nolo yesterday that if I want to run latest PiTool then I SHOULD uninstall Nolo completely.

    Good luck!
  • edited December 2020
    well well well,

    so i can see the controleur, but tracking not works for headset et no for contrôleur :/

    so the best things i got, is the tracking works with headset but no controleur on 3D view

    see the controleur but no tracking, no headset tracking and no controleur tracking

    i m totaly lost :/
  • You might need to run room setup in Pitool and then repeat in SteamVR Also, try unpluging Nolo Headset marker and then plug it back in again beforehand...

  • I would re-pair all Nolo items also

  • Tracking not work :/

    i desinstall evrythin

    i reinstall Pitools 264 - nolohome on steam

    i re pair all nolo items and  do room setup on pitool and steamVR and

    the tracking not work

  • You HAVE to uninstall Nolo Home!!! If you have updated firmware on both controllers, headset and base station then you dont need it any more. Uninstall from Steam then remove ALL traces of Nolo from your computer.
  • edited December 2020
    Installing Nolo Home via Steam will cause a conflict in StemVR when trying to run Pimax as SteamVR wont know which drivers to use, Nolo or Pimax. Have you set folder properties to Show Hidden Files and Folder? You will need to do this to access the %AppData% and from there deleted all trace of Nolo.

    As you had installed Nolo, SteamVR and Pimax PiTool together it may have messed up your openvr.vrpath file...see below

  • See below reddit:


    It might help explain why you are having trouble...

     The same thing happened to me - here's what Steam support told me, and it worked.

    The key thing is to either run vrpathreg or delete openvr.vrpath in the openvr folder.

    Hello Michael,

    Thank you for contacting Steam Support.

    You may need to fix the installation paths for SteamVR.

    Navigate to: ...Steam\steamapps\common\SteamVR\bin\win64

    Run vrpathreg and fix the paths to the correct drive letter/directory, or delete the openvr.vrpath file in <user>/AppData/Local/openvr. This folder may be hidden, so ensure you have these set to visible:

    -Open Folder Options by clicking the Start button , clicking Control Panel, clicking Appearance and Personalization, and then clicking Folder Options. -Click the View tab. -Under Advanced settings, click Show hidden files and folders, and then click OK.)

    For Windows 10, do the following to show hidden files/folders:

    Select the “Start” button, then choose “File Explorer“. Select the “View” tab.

    Check the “Hidden items” check box to view hidden items.

    level 2

    Thank you so much, Michael! The two things separately didn't fix it, but after much messing around, I had to delete the openvr.vrpath first, then run vrpathreg. Thank you, and thanks again! I missed my Vive way too much!"

  • PiTool already has up to date Nolo drivers therefore, Installing Nolo Home will cause conflict where tracking doesnt work
  • edited December 2020
    to resume

    I removed the folder and files :


    i remove from steamVR :


    i remove Pitools

    i used revoUninstaller to remove all trace of it

    i closed steam

    i install Pitool V1.0.1.264

    so now i start SteamVR, i do the room setup, i repair all nolo (controlers, base, headset tracking)

    Now :
    i start Pitool  V1.0.1.264
    i start Steam
    I start SteamVR

    and now

    the headset tracking works, the controlleur are not in the 3D view, but i can push buttons.

    i can turn in 360 with controlleur.

    But i can't show the controleur nothing are in the 3D view

    is better, but still missing the controlleur.

    the things is i can move, only the head in 360 and not move far way my place:/

    is better, still missing a thing

    thanks for u help

  • good luck

  • :'(

    still not working :'(
  • Hello,
    so after hour and hour to try the problem is my Base station was broken

    THnaks nolo for replace my base stations

    but now my left controlleur triger broke :'(

    i m so desapointed :'(

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!