About the base station repair tool

edited December 2018 in Support
Recently we built a base station repair tool for a specific symptom of the base station - The orientation error when you move forward in reality, you move to the right or left in the game.

We do not recommend all users to try this tool because it could cause more trouble if you don't follow the instructions correctly.

If you have any problem, please contact support@nolovr.com first and we will help you figure it out. We are also willing to provide remote assistant via TeamViewer if you need to use the repair tool.

Thank you for your understanding.


  • Sorry, my bad, I did it and the base unit is totally malfunction.

    What should I do? Do I have to return the base unit for repairing.?

  • Does the base station need to be turned on (motor running) before repair?

    I guess it will not be the same with the motor running that with the motor off

  • I think the base station should be running while connected to the PC, but I haven't tried this tool.
  • @virtualreality The base station doesn't need to be turned on. We do not recommend users to try this tool without contacting support@lyrobotix.com.
  • @admin ;
    I wrote to support@lyrobotix.com. And they have been silent for a week now.
  • They take a while to respond, I think they've been very busy on software updates to the driver and working with RiftCat.
  • @Mrdominic215 which email address did you use? We check our support email account every day but didn't receive your message. Could you send us again?
  • edited November 2018
    I used the repair tool as controllers movement became extremely laggy in SteamVr probably after installing vorpx and directx .
    (Prior I tried to used it for reverted axis - but really what helped was double touching turn on buttons on hand controllers.).

    I had opened repair tool this time, but forgot cable in other pc, realizing it putting it now to the pc running repair tool where repair button was not reacting (since I had plugged into other pc) - after plugging in cable, the repair process started running automatically - but it took much time, so I closed the tool, but now my nolo base won't turn on nor charge nor light, (led blinked red only once after long time later trying - when I was pushing any buttons, could not resimulate again) -

    I got Windows 10 error  "The last USB device malfunctioned and Windows doesn’t recognize it" - in device manager "device descriptor request failed".

    This all just because closing repair tool, when it looked stuck for ages? In the tool, there is a single word "Warning" without any more stronger text attentions, but I didn't expect closing stuck utility to causing this.

    Firmware update tool, doesn't see that base is connected to the pc.

    Please help, should I claim a guarantee fix and support, or is the device lost?
    Thank you

  • Could be the device bricked with any chance to reversing to factory defaults?
  • @FantomX1 We replied to your email. 

  • edited November 2018
    @admin Thank you very much :). The suggested fix of holding the back small pairing button, then holding the power on button together until the cable was plugged in - worked. The device was displayed in device manager as 'stm device in dfu mode', just the automatic 'normal' repair button didn't start and not even when I clicked it - normal repair. 

    So I was considering doing 'firmware' update, who knows maybe it would help, but seeing 'stm device in dfu mode' googled it, read in repair app 'mandatory repair' blinking orange - although only my power button was blinking red, and in manual paper reading orange = DFU mode. I tried mandatory mode after following the press sequence. And it was fixed like a charm in 5 seconds. Perfect support in a few next hours, the next working day.
  • @FantomX1, thanks for your update and sharing your experience here. We will try our best to reply emails within 24 hours on the working days.
  • edited March 2019
    Hello @admin,

    I downloaded the Nolo home software. I connected the base station with a normal USB cable. It was updating the firmware then it said update failed. My base station is not turning on anymore. What should I do? I tried everything above without success.

    Thank you.
  • @XNOLOUSERX Hi, please send us your preferred time slot between 10:00-18:00 UTC+8 Mon-Fri with your Teamviewer ID and password. We would like downgrade the firmware for you.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!