Notification for Pimax users! Please do not UPDATE the firmware []-)



  • @RugbyGoth Hi, thanks for your update. We replied to your emails.  :)
  • edited July 2019
    Yes, and it works now... kind of.
    I don't have the nolo + vive controller, only vive. 
    But honestly it's not playable AT ALL
    As you can see on the video, the controller position seems to be updated like once every second, it's not smooth AT ALL!
    And it looses the referential like once every 30 sec and I have to double click the power on button to get it somehow in the good place. The head tracker has also difficulty to stay in place and my front facing position is jittering also.

    So, right now, for me Nolo is totally unusable... I thought it was a finished product, it seems it's in alpha stage and I'm kind of tester... disappointed.
  • @RugbyGoth Hi, thanks for your update. Sorry for any inconvenience caused. As we explained before, we didn't make the pimax software Pitool. So for now, it's kind of software issue. Our standalone VR headsets users didn't have similar issue. And you can try your NOLO CV1 in the Visualizer under the NOLO HOME. It's unity software to test the hardware. If you can use the devices smoothly there, which means it must be a software issue. We can try to downgrade the firmware for you to see whether it works better with Pitool latest version. 
  • Thansk for the answer, in visualizer everything is smooth, some minor lags, but nothing compared to the beat saber or pavlov experience.
    I try to talk with PiMax support also, we will go for the downgrade or not after they answered.
  • @RugbyGoth Hi, no problem. If you need to downgrade the firmware, please let us know.
  • edited July 2019
    @admin Downgrade made things worse. PiTool see the Controller and base station being connected, but it says they are not tracked "Place the Helmet in the visible position of the base station" it says but it is already in the position...
    Also, in Nolo home visualizer Head tracker and controllers are off by 90° to the left (I need to turn my head 90° to te right to be in front of the base station in the visualizer, same with controllers)
  • edited July 2019
    Thanks to @Lathander post I've figured out the 90° issue. I had to calibrate.
    But still, PiTool can't see the tracking made by Nolo with the firmware version you installed.
  • edited July 2019
    @RugbyGoth ;For me,  I can see the tracker but the position is very weird. it's 20cm closer and 10 cm down to HMD than actual position.    And HMD position moves about double time more than real movement. I'm not sure what is the problem yet. but I guess both cases are some kind related. I hope it's not the hardware problem. I have spend many times already to fix the issue for now. 
  • Position of the tracker is also weird for me like you. Also, I re-updated my nolo firmware to latest because I couldn't use it with the firmware they downgraded to. I'm using PiTool 129 and it's best than 144 but I still have some lags with controllers, specially left one.
  • @Lathander Thanks for your message. Only Pimax 4k is officially compatible with NOLO CV1. So Pimax 8K may not be completed compatible with NOLO. As the compensation value of the rotation axis may be different. 
    @Lathander Thanks for your reply. Pimax 5K will encounter the same tracking issue with Pimax 8K. As we didn't make the pitool software, so we're not sure the reason why it cannot be played with the 2.1 version firmware. There were many users using 2.1 version or the latest version together with Pimax 4K headset. We will also try to contact Pimax team about this issue. 
  • Hello there, can u give more information about what firmware is Ok for Pimax 4k and how downgrade if necessary ?

  • @Pimax_fr Hi, pimax 4K is compatible with the latest firmware. (That's what we received from Pimax support) Some pimax users asked us to downgrade their firmware. If you want to downgrade, just email us at 
  • edited April 2020
    Hi, is this still an ongoing issue,as Later Piplay states "Synthesize Nolo SDK",but not in the actual patch notes just support,as my Pimax 5K can not see my Nolo device at all ?
  • @wigwamjam
    Hi, thanks for your message. Please try the latest version of Pitool. As we know, Pimax headset can use the latest version of Pitool with latest firmware of NOLO CV1. 
  • AM I safe to update Nolo firmware to latest version in conjunction with latest PiTool version
  • @siege
    Hi, we checked with Pimax, and they said they support the latest NOLO firmware. 
  • @admin

    Updated Nolo firmware and am now unable to power on the base station. All I get is a flashing red light onm the power button on top. What has happened? I'm get really fed up with this Nolo setup as it's more hassle than its worth. Please advise.
  • @siege
    Hi, it seems the problem has been solved. (We received your email.) Hope you enjoy your NOLO. If you have any question, please feel free to contact us at 
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!