BUG: Latest firmware is unusable

edited March 2019 in General
The latest firmware (supplied with Nolo HOME) has a *major* bug when using it in conjunction with the PC SDK (latest). When recentering (double-click on system button), the headset marker orientation is 90 degrees clockwise off center. This makes using Nolo impossible.

If you are using NoloVR with iVRy (or perhaps other PC based solutions), *YOU SHOULD NOT UPGRADE TO THE LATEST FIRMWARE*. If you have already upgraded, please contact @admin for assistance with downgrading your firmware.


  • @iVRy ;It is fixed. You just need to spherically scroll in all directions the controller and it will be determined where it is actually located. And since the centering is quite erroneous, I thought that with my crutches for pimax is
  • @iVRy - Can you confirm , what TheDeaX is claiming? That the new firmware indeed works after swirling around the wrist a bit first to collect surrounding magnetic field and then double clicking the system button to center orientation to the base station?
  • @dlgonzo I'll try it out, but as the Nolo hardware doesn't contain magnetometers that explanation does not make a lot of sense. In any case it's always exactly 90 degrees out, which was a startup bug in other firmwares that got corrected once you recentered. So it seems that bug has gotten worse.
  • No, as expected TheDeaX's solution has no effect. In any case the Pimax driver doesn't support any version of the "Oculus Go" firmware, so most likely they are referring to an unrelated bug in the Pimax driver.
  • I have wasted countless hours working around NoloVR SDK and firmware bugs. I'm rapidly losing whatever patience I may have had. When NoloVR can produce a working firmware I will look at this again. Until then I will advise iVRy users to stay far away from this firmware update (which only appears to add bugs, it doesn't have any actual improvements as far as I can see).
  • edited March 2019
  • I've managed to work around this by calling:

    NOLOVR::SetHmdCenter(NOLOVR::NVector3(0.0f, 0.0f, 0.0f));

    just after NOLOVR::OpenNoloZeroMQ() in the driver startup. *Seems* to fix the problem. Tested it with 1.09 and 1.10 Nolo HOME firmwares.

    The latest ( iVRy driver contains this fix for anyone using NoloVR with the iVRy driver.

  • @iVRy ; can you detail how to fix the problem? In my case its almost impossible to use in full body tracking because the controllers get calibrated but the hip follows

  • edited March 2019
    @Dj_Gelo_Official ; I'm not really understanding what you mean by "controllers get calibrated but the hip follows", but I'd recommend downgrading to the the Nolo HOME 1.09 firmware. This firmware seems to have bugs and doesn't really add anything noticeable. The firmware doesn't even work properly with Nolo's Visualizer for NoloVR HOME 1.10 (the software it's shipped with), so it looks like it hasn't been tested well. The "fix" (I'm still not convinced) requires you to be using the latest PC SDK and have access to the source code of whatever driver you're using.

  • @iVRy thanks for your report. I'll pass your message to our dev team. But most users of standalone VR headset got positive feedback of the latest firmware. 
  • @admin "La la la, everything is fine" is not a valid answer to a real problem. If you want to see this for yourself, try recentering while using the Visualizer in Nolo HOME 1.10. I will be passing on any user that has problems with the new firmware to Nolo support, as it is an issue that is firmly with the Nolo software. If I was your company I would treat this problem as "urgent", before you get too many support emails.

    My software should not be manipulating the tracking info provided by the Nolo hardware, particularly when *every* other firmware release gives correct tracking data. In any case, the problem could be in the Nolo server software when combined with the new firmware. AFAIK Nolo HOME doesn't use the Nolo server software.
  • http://drive.google.com/open?id=14_QJII1SQDTvIoU4yodj9FniAhmcsUZw
    As you said, we tested it. Please check it. We were using the latest version of NOLO HOMO and the latest firmware. 
  • @admin Perhaps the issue is with the older NoloVR hardware? Or something else? I can run this test (Nolo HOME 1.10 Visualizer) on my machine without any other software running, and I get the issue. Clearly there is an issue with the latest firmware, as this issue has never been present until the latest software. As your company appears to be denying there is an issue, I don't know what to do at this point. Unfortunately poor quality Nolo software reflects on my software, so I cannot do nothing.
  • @admin Please more test for the iVRy+Nolo users, before the firmware release. 
    I didn't update the latest firmware, yet. 
    Your QA team has to full-test for the PSVR with nolo users.

  • @iVRy May I check with you if you have two monitors connecting to your pc?
  • @admin I have 3. I sincerely hope the Nolo *tracking* hardware/software has no functionality linked to how many monitors are present on a system. Please do not even suggest that I change my system setup to accommodate a bug in the NoloVR firmware.
  • @iVRy proof solution 
  • @TheDeaX This is absolutely not the problem we have.
    I don't knwo what is your setup (headset + nolo firmware + ivry version) but for mine (PSVR + 1.10Home Hardware firmware update + Latest Ivry Version) it's a nightmare to use anything in VR as the center function is just broken, and the base station was positioned like Ivry said at 90° from the front center.

    Certainly that the latest Ivry update tweaked it to make it work, but now the centering function seems wrong.

    So, NOLO, we wait, once again, like always, we just hope for you to correct things we bought... three times from my purchase, and that's note supposed to be like that with a 250$ product...
  • Also, here's my issue with this firmware, trying to recenter everything, with rarely a good result...
    (Just have to think if this issue is caused by your firmware, or caused by the hot fix Ivry made to make your thing working (the 90° orientation problem), as we never been able to test it correctly without this hot fix :/

    In any case, you should make sure that the first issue is fixed IN STEAM VR (Yes, in your NOLO Visualizer, there's no problem) then after that Ivry could try without the hot fix to see if it's finally working like it should I guess.

  • @cyberkevin Are you using the latest version of iVRy + NOLO CV1 latest firmware? It seems work fine in your video. Didn't find out the 90 degress problem. 

  • @idanliu I was using the latest version of everything, yes.
    Sorry, it was really late for me, and forgot to explain a little bit the video :/

    So as you can see, while I try to center, I always extend my arms in front of me, to the base station, and try, again, again, and again, but it never is correctly sync :/ 

    The 90° problem, I had it with the previous ivry's driver version, but he hot fixed it as he shouldn't have, it's just a patch to wait for a correct correction from NOLO ^^
    It's possible that this anomaly is related to both this 90° problem and the hot fix.

    For now, NOLO downgraded my Firmware, I'll take a look at the result on latest Ivry's driver and let it know here ^^
  • @TheDeaX So, what are you saying? That I'm wrong and there is no bug in the firmware? Using the Nolo supplied SDKs everything works correctly with every other firmware version except this one and reverting the firmware to previous fixes the issue.

    @cyberkevin The "fix" is one line of code at Nolo SDK startup. You've already tried the version without the "fix", it's the previous version you reported issues with.

  • edited March 2019
    @iVRy Yes that's exactly what I said :
    Latest version with fix, I have the issue of my video : no correct recenter function.
    and the previous one, the 90° orientation issue (and haven't been able to test if recenter had problem too because of that)
    Still haven't tried with the old firmware.

    I think this issue is so boring as it seems like NOLO changed something, they know what as the Visualizer have no problem for tracking the NOLO CV1, they give a new SDK if I understand that, and it don't works with the new firmware, but still with the old one... well... NOLO missed something, that's all, and now we wait.
  • Tried with the Nolo Home 1.09 firmware release for NOLO CV1, no issue at all.
    Just really sad to not being able to use the new firmware, so I wait for NOLO update now :/ 

    Also @iVRy , good job for this automatic orientation stabilizer you made, it works pretty well, even if sometimes it try to do too much for nothing, before doing a better job on the next auto recenter ^^
    It needs improvement, but it's really enjoyable as it is already !
    I haven't tried to see if there's problem when you try to also manually center it as I didn't needed it at all in two sessions ^^
    I'm gladly surprise ! ^^

    So the only problem is that sometimes it sync it too far, but it's not that much far, so even when it does this, it's way more enjoyable than the drifting issue we had ! :D
  • @cyberkevin The Nolo headtracker orientation is terrible, I'm certain they can improve this. It has a lot of "jitter". You can see this by switching off "device orientation" in the iVRy settings. I'll probably need to put a filter onto it to smooth it out a bit for the auto-centering.
  • I don't have that "MUCH" jitter, but I know what you mean, yeah, they can really do better :/

    We hope, for now, if your auto correction can improve, it will be really better, the only problem that will stay is that even the position tracking of Nolo head tracker is a little bit slower than it should, we can feel it when our head movement jitter a little and the virtual world seems to jitter too a little bit ^^ (something that not happen on PS4, VIVE, etc... but that's normal as we based informations on PSVR sensors and Nolo tracking, and they are not perfectly sync at the end :/

    (still WAY BETTER than nothing, and way better than PSMove Service head tracking thing or trinus solution)

    Of course, the best solution will be when NOLO position and orientation tracking will be at at least 120Hz, and corrected a little for the jitter effect.

    Come on @admin , it just need some improvements, and your product will be the best solution out there ! :D 
  • edited April 2019
    Seems like the center calibration drifts over time. Its pretty annoying since you have to Try&Error to find the actual center while calibrating. Normaly the center is the base station. But the more you use VR its some random angle.

    Workaround: The only "solution" is to re-plug the HMD while using VR while looing at the base station. This only works temporarly because this bug will happen again after time.

    Im using 1.10 sadly with new firmware. I wish to downgrade.
    Why is there no option to select firmwares yet... ? This is required since NoloVR is still in development so people have the choice to downgrade if something isnt working. Without waiting for the support.
  • @Externet Hi, thanks for your message. We would like to book a remote session for you to downgrade the firmware. Please send us your preferred time slot between 10:00-18:00 UTC+8 Mon-Fri with your Teamviewer ID and password. 
  • I'm using Pimax 8k. 
    After updating to the final firmware version yesterday, we are experiencing a problem where everything goes wrong to 90 degrees.

    If you turn the base station 90 degrees to fix it or re-position the marker, the problem will not be corrected and the controller and headset will be abnormally trekked.

    When you received the firmware downgrade service, did you resolve it only with the base station?
    Have you lowered the firmware for all products?

    I wonder how you solved the problem.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!